[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200519165837.883035d3228c582b9bff1d77@linux-foundation.org>
Date: Tue, 19 May 2020 16:58:37 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Sebastian Andrzej Siewior <bigeasy@...utronix.de>
Cc: linux-kernel@...r.kernel.org,
Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...nel.org>,
Steven Rostedt <rostedt@...dmis.org>,
Will Deacon <will@...nel.org>,
Thomas Gleixner <tglx@...utronix.de>,
"Paul E . McKenney" <paulmck@...nel.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
linux-mm@...ck.org
Subject: Re: [PATCH 4/8] mm/swap: Use local_lock for protection
On Tue, 19 May 2020 22:19:08 +0200 Sebastian Andrzej Siewior <bigeasy@...utronix.de> wrote:
> From: Ingo Molnar <mingo@...nel.org>
>
> The various struct pagevec per CPU variables are protected by disabling
> either preemption or interrupts across the critical sections. Inside
> these sections spinlocks have to be acquired.
>
> These spinlocks are regular spinlock_t types which are converted to
> "sleeping" spinlocks on PREEMPT_RT enabled kernels. Obviously sleeping
> locks cannot be acquired in preemption or interrupt disabled sections.
>
> local locks provide a trivial way to substitute preempt and interrupt
> disable instances. On a non PREEMPT_RT enabled kernel local_lock() maps
> to preempt_disable() and local_lock_irq() to local_irq_disable().
>
> Add swapvec_lock to protect the per-CPU lru_add_pvec and
> lru_lazyfree_pvecs variables and rotate_lock to protect the per-CPU
> lru_rotate_pvecs variable
>
> Change the relevant call sites to acquire these locks instead of using
> preempt_disable() / get_cpu() / get_cpu_var() and local_irq_disable() /
> local_irq_save().
>
> There is neither a functional change nor a change in the generated
> binary code for non PREEMPT_RT enabled non-debug kernels.
>
> When lockdep is enabled local locks have lockdep maps embedded. These
> allow lockdep to validate the protections, i.e. inappropriate usage of a
> preemption only protected sections would result in a lockdep warning
> while the same problem would not be noticed with a plain
> preempt_disable() based protection.
>
> local locks also improve readability as they provide a named scope for
> the protections while preempt/interrupt disable are opaque scopeless.
>
> Finally local locks allow PREEMPT_RT to substitute them with real
> locking primitives to ensure the correctness of operation in a fully
> preemptible kernel.
> No functional change.
>
> ...
>
> --- a/include/linux/swap.h
> +++ b/include/linux/swap.h
> @@ -12,6 +12,7 @@
> #include <linux/fs.h>
> #include <linux/atomic.h>
> #include <linux/page-flags.h>
> +#include <linux/locallock.h>
Could we please make these local_lock.h and local_lock_internal.h? Making
the filenames different from everything else is just irritating!
> + local_lock(swapvec_lock);
It's quite peculiar that these operations appear to be pass-by-value.
All other locking operations are pass-by-reference - spin_lock(&lock),
not spin_lock(lock). This is what the eye expects to see and it's
simply more logical - calling code shouldn't have to "know" that the
locking operations are implemented as cpp macros. And we'd be in a
mess if someone tried to convert these to real C functions.
Which prompts the question: why were all these operations implemented
in the processor anyway? afaict they could have been written in C.
Powered by blists - more mailing lists