[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200521205223.175957-1-tyhicks@linux.microsoft.com>
Date: Thu, 21 May 2020 15:52:23 -0500
From: Tyler Hicks <tyhicks@...ux.microsoft.com>
To: Kees Cook <keescook@...omium.org>
Cc: Anton Vorontsov <anton@...msg.org>,
Colin Cross <ccross@...roid.com>,
Tony Luck <tony.luck@...el.com>,
Pavel Tatashin <pasha.tatashin@...een.com>,
linux-kernel@...r.kernel.org
Subject: [PATCH -next] pstore/ram: Undefine the correct macro after a recent renaming
Undefine parse_u32, instead of parse_size, as the name of the macro
recently changed but the #undef directive wasn't updated at that time.
Fixes: 6b31e99b85b0 ("pstore/ram: Refactor DT size parsing")
Signed-off-by: Tyler Hicks <tyhicks@...ux.microsoft.com>
---
Hi Kees - Here's a minor fixup that I noticed was needed while reviewing
your for-next/pstore branch. It is only build-tested but I think that's
all that's needed here.
Tyler
fs/pstore/ram.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fs/pstore/ram.c b/fs/pstore/ram.c
index df8965817c7b..ca6d8a867285 100644
--- a/fs/pstore/ram.c
+++ b/fs/pstore/ram.c
@@ -674,7 +674,7 @@ static int ramoops_parse_dt(struct platform_device *pdev,
parse_u32("flags", pdata->flags, 0);
parse_u32("max-reason", pdata->max_reason, pdata->max_reason);
-#undef parse_size
+#undef parse_u32
/*
* Some old Chromebooks relied on the kernel setting the
--
2.25.1
Powered by blists - more mailing lists