[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200521233041.GG28818@bombadil.infradead.org>
Date: Thu, 21 May 2020 16:30:41 -0700
From: Matthew Wilcox <willy@...radead.org>
To: Dave Chinner <david@...morbit.com>
Cc: linux-fsdevel@...r.kernel.org, linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
"Kirill A. Shutemov" <kirill@...temov.name>
Subject: Re: [PATCH v4 10/36] fs: Make page_mkwrite_check_truncate thp-aware
On Fri, May 22, 2020 at 08:01:39AM +1000, Dave Chinner wrote:
> On Fri, May 15, 2020 at 06:16:30AM -0700, Matthew Wilcox wrote:
> > if (page->mapping != inode->i_mapping)
> > return -EFAULT;
> >
> > /* page is wholly inside EOF */
> > - if (page->index < index)
> > - return PAGE_SIZE;
> > + if (page->index + hpage_nr_pages(page) - 1 < index)
> > + return thp_size(page);
>
> Can we make these interfaces all use the same namespace prefix?
> Here we have a mix of thp and hpage and I have no clue how hpages
> are different to thps. If they refer to the same thing (i.e. huge
> pages) then can we please make the API consistent before splattering
> it all over the filesystem code?
Yes, they're the same thing. I'll rename hpage_nr_pages() to thp_count().
Powered by blists - more mailing lists