lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 22 May 2020 20:02:37 +0300
From:   Amir Goldstein <amir73il@...il.com>
To:     Miklos Szeredi <mszeredi@...hat.com>
Cc:     Al Viro <viro@...iv.linux.org.uk>,
        overlayfs <linux-unionfs@...r.kernel.org>,
        linux-fsdevel <linux-fsdevel@...r.kernel.org>,
        lkml <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] ovl: make private mounts longterm

> > > -     mntput(ofs->upper_mnt);
> > > -     for (i = 1; i < ofs->numlayer; i++) {
> > > -             iput(ofs->layers[i].trap);
> > > -             mntput(ofs->layers[i].mnt);
> > > +
> > > +     if (!ofs->layers) {
> > > +             /* Deal with partial setup */
> > > +             kern_unmount(ofs->upper_mnt);
> > > +     } else {
> > > +             /* Hack!  Reuse ofs->layers as a mounts array */
> > > +             struct vfsmount **mounts = (struct vfsmount **) ofs->layers;
> > > +
> > > +             for (i = 0; i < ofs->numlayer; i++) {
> > > +                     iput(ofs->layers[i].trap);
> > > +                     mounts[i] = ofs->layers[i].mnt;
> > > +             }
> > > +             kern_unmount_many(mounts, ofs->numlayer);
> > > +             kfree(ofs->layers);
> >
> > That's _way_ too subtle.  AFAICS, you rely upon ->upper_mnt == ->layers[0].mnt,
> > ->layers[0].trap == NULL, without even mentioning that.  And the hack you do
> > mention...  Yecchhh...  How many layers are possible, again?
>
> 500, mounts array would fit inside a page and a page can be allocated
> with __GFP_NOFAIL. But why bother?  It's not all that bad, is it?

FWIW, it seems fine to me.
We can transfer the reference from upperdir_trap to layers[0].trap
when initializing layers[0] for the sake of clarity.

Thanks,
Amir.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ