[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200522051931.54191-1-jhubbard@nvidia.com>
Date: Thu, 21 May 2020 22:19:27 -0700
From: John Hubbard <jhubbard@...dia.com>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: Souptick Joarder <jrdr.linux@...il.com>,
Matthew Wilcox <willy@...radead.org>,
Jani Nikula <jani.nikula@...ux.intel.com>,
Joonas Lahtinen <joonas.lahtinen@...ux.intel.com>,
Rodrigo Vivi <rodrigo.vivi@...el.com>,
David Airlie <airlied@...ux.ie>,
Daniel Vetter <daniel@...ll.ch>,
Chris Wilson <chris@...is-wilson.co.uk>,
Tvrtko Ursulin <tvrtko.ursulin@...el.com>,
Matthew Auld <matthew.auld@...el.com>,
<intel-gfx@...ts.freedesktop.org>,
<dri-devel@...ts.freedesktop.org>,
LKML <linux-kernel@...r.kernel.org>, <linux-mm@...ck.org>,
John Hubbard <jhubbard@...dia.com>
Subject: [PATCH v2 0/4] mm/gup, drm/i915: refactor gup_fast, convert to pin_user_pages()
The purpose of posting this series is to launch a test in the
intel-gfx-ci tree. (The patches have already been merged into Andrew's
linux-mm tree.)
This applies to today's linux.git (note the base-commit tag at the
bottom).
Changes since V1:
* Fixed a bug in the refactoring patch: added FOLL_FAST_ONLY to the
list of gup_flags *not* to WARN() on. This lead to a failure in the
first intel-gfx-ci test run [1].
[1] https://lore.kernel.org/r/159008745422.32320.5724805750977048669@build.alporthouse.com
Original cover letter:
This needs to go through Andrew's -mm tree, due to adding a new gup.c
routine. However, I would really love to have some testing from the
drm/i915 folks, because I haven't been able to run-time test that part
of it.
Otherwise, though, the series has passed my basic run time testing:
some LTP tests, some xfs and etx4 non-destructive xfstests, and an
assortment of other smaller ones: vm selftests, io_uring_register, a
few more. But that's only on one particular machine. Also, cross-compile
tests for half a dozen arches all pass.
Details:
In order to convert the drm/i915 driver from get_user_pages() to
pin_user_pages(), a FOLL_PIN equivalent of __get_user_pages_fast() was
required. That led to refactoring __get_user_pages_fast(), with the
following goals:
1) As above: provide a pin_user_pages*() routine for drm/i915 to call,
in place of __get_user_pages_fast(),
2) Get rid of the gup.c duplicate code for walking page tables with
interrupts disabled. This duplicate code is a minor maintenance
problem anyway.
3) Make it easy for an upcoming patch from Souptick, which aims to
convert __get_user_pages_fast() to use a gup_flags argument, instead
of a bool writeable arg. Also, if this series looks good, we can
ask Souptick to change the name as well, to whatever the consensus
is. My initial recommendation is: get_user_pages_fast_only(), to
match the new pin_user_pages_only().
John Hubbard (4):
mm/gup: move __get_user_pages_fast() down a few lines in gup.c
mm/gup: refactor and de-duplicate gup_fast() code
mm/gup: introduce pin_user_pages_fast_only()
drm/i915: convert get_user_pages() --> pin_user_pages()
drivers/gpu/drm/i915/gem/i915_gem_userptr.c | 22 +--
include/linux/mm.h | 3 +
mm/gup.c | 153 ++++++++++++--------
3 files changed, 109 insertions(+), 69 deletions(-)
base-commit: 051143e1602d90ea71887d92363edd539d411de5
--
2.26.2
Powered by blists - more mailing lists