lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Sun, 24 May 2020 09:00:28 +0200
From:   Markus Elfring <>
To:     Dejin Zheng <>,,
Cc:     Ard Biesheuvel <>, Barry Song <>,
        Baruch Siach <>,
        Fabio Estevam <>,
        Florian Fainelli <>,
        Greg Kroah-Hartman <>,
        Heiko Stübner <>,
        Kevin Hilman <>,
        Linus Walleij <>,
        Michal Simek <>,
        Paul Cercueil <>,
        "Rafael J. Wysocki" <>,
        Ray Jui <>,
        Scott Branden <>,
        Shawn Guo <>,
        Vladimir Zapolskiy <>,
        Wolfram Sang <>,,
        Coccinelle <>
Subject: Re: [PATCH v2 1/2] drivers: provide devm_platform_request_irq()

> It will call devm_request_irq() after platform_get_irq() function
> in many drivers, sometimes, it is not right for the error handling
> of these two functions in some drivers. so provide this function
> to simplify the driver.

I recommend to improve also this change description.
How do you think about a wording variant like the following?

   The function “devm_request_irq” is called after the
   function “platform_get_irq” in many drivers.
   The exception handling is incomplete there sometimes.
   Thus add a corresponding wrapper function for the simplification
   of the drivers.

Will a companion script for the semantic patch language (Coccinelle software)
become helpful for further support of collateral evolution?


Powered by blists - more mailing lists