lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 27 May 2020 12:04:47 -0500
From:   "Gustavo A. R. Silva" <gustavoars@...nel.org>
To:     Jason Gunthorpe <jgg@...pe.ca>
Cc:     Doug Ledford <dledford@...hat.com>, linux-rdma@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH] IB/core: Use sizeof_field() helper

On Wed, May 27, 2020 at 01:44:52PM -0300, Jason Gunthorpe wrote:
> On Wed, May 27, 2020 at 09:41:52AM -0500, Gustavo A. R. Silva wrote:
> > Make use of the sizeof_field() helper instead of an open-coded version.
> > 
> > Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> > ---
> >  drivers/infiniband/core/sa_query.c     | 8 ++++----
> >  drivers/infiniband/core/uverbs_cmd.c   | 2 +-
> >  drivers/infiniband/core/uverbs_ioctl.c | 2 +-
> >  3 files changed, 6 insertions(+), 6 deletions(-)
> 
> What kind of tool are you using for this? It seems to miss a lot, I
> added in a few others to this patch and applied it, thanks:
> 

Hi Jason,

I was just doing a "terrain recognition" with grep. I certainly
wasn't expecting spaces between the sizeof operator and the opening
parenthesis: "sizeof ((struct ib_sa_mcmember_rec *) 0)->field".

Also, I was just running grep in drivers/infiniband/

I'll run a cocci script next time...

Thanks for your feedback. :)
--
Gustavo

> diff --git a/drivers/infiniband/core/sa_query.c b/drivers/infiniband/core/sa_query.c
> index 8f70c5c38ab7c3..a2ed09a3c714a9 100644
> --- a/drivers/infiniband/core/sa_query.c
> +++ b/drivers/infiniband/core/sa_query.c
> @@ -420,7 +420,7 @@ static const struct ib_field opa_path_rec_table[] = {
>  
>  #define MCMEMBER_REC_FIELD(field) \
>  	.struct_offset_bytes = offsetof(struct ib_sa_mcmember_rec, field),	\
> -	.struct_size_bytes   = sizeof ((struct ib_sa_mcmember_rec *) 0)->field,	\
> +	.struct_size_bytes   = sizeof_field(struct ib_sa_mcmember_rec, field),	\
>  	.field_name          = "sa_mcmember_rec:" #field
>  
>  static const struct ib_field mcmember_rec_table[] = {
> @@ -504,7 +504,7 @@ static const struct ib_field mcmember_rec_table[] = {
>  
>  #define SERVICE_REC_FIELD(field) \
>  	.struct_offset_bytes = offsetof(struct ib_sa_service_rec, field),	\
> -	.struct_size_bytes   = sizeof ((struct ib_sa_service_rec *) 0)->field,	\
> +	.struct_size_bytes   = sizeof_field(struct ib_sa_service_rec, field),	\
>  	.field_name          = "sa_service_rec:" #field
>  
>  static const struct ib_field service_rec_table[] = {
> @@ -710,7 +710,7 @@ static const struct ib_field opa_classport_info_rec_table[] = {
>  
>  #define GUIDINFO_REC_FIELD(field) \
>  	.struct_offset_bytes = offsetof(struct ib_sa_guidinfo_rec, field),	\
> -	.struct_size_bytes   = sizeof((struct ib_sa_guidinfo_rec *) 0)->field,	\
> +	.struct_size_bytes   = sizeof_field(struct ib_sa_guidinfo_rec, field),	\
>  	.field_name          = "sa_guidinfo_rec:" #field
>  
>  static const struct ib_field guidinfo_rec_table[] = {
> diff --git a/drivers/infiniband/core/ud_header.c b/drivers/infiniband/core/ud_header.c
> index 29a45d2f8898e1..d65d541b9a2587 100644
> --- a/drivers/infiniband/core/ud_header.c
> +++ b/drivers/infiniband/core/ud_header.c
> @@ -41,7 +41,7 @@
>  
>  #define STRUCT_FIELD(header, field) \
>  	.struct_offset_bytes = offsetof(struct ib_unpacked_ ## header, field),      \
> -	.struct_size_bytes   = sizeof ((struct ib_unpacked_ ## header *) 0)->field, \
> +	.struct_size_bytes   = sizeof_field(struct ib_unpacked_ ## header, field), \
>  	.field_name          = #header ":" #field
>  
>  static const struct ib_field lrh_table[]  = {
> diff --git a/include/rdma/uverbs_ioctl.h b/include/rdma/uverbs_ioctl.h
> index 5bd2b037e9147c..0418d7bddf3e0c 100644
> --- a/include/rdma/uverbs_ioctl.h
> +++ b/include/rdma/uverbs_ioctl.h
> @@ -420,9 +420,9 @@ struct uapi_definition {
>  		.scope = UAPI_SCOPE_OBJECT,                                    \
>  		.needs_fn_offset =                                             \
>  			offsetof(struct ib_device_ops, ibdev_fn) +             \
> -			BUILD_BUG_ON_ZERO(                                     \
> -			    sizeof(((struct ib_device_ops *)0)->ibdev_fn) !=   \
> -			    sizeof(void *)),				       \
> +			BUILD_BUG_ON_ZERO(sizeof_field(struct ib_device_ops,   \
> +						       ibdev_fn) !=            \
> +					  sizeof(void *)),                     \
>  	}
>  
>  /*
> @@ -435,9 +435,9 @@ struct uapi_definition {
>  		.scope = UAPI_SCOPE_METHOD,                                    \
>  		.needs_fn_offset =                                             \
>  			offsetof(struct ib_device_ops, ibdev_fn) +             \
> -			BUILD_BUG_ON_ZERO(                                     \
> -			    sizeof(((struct ib_device_ops *)0)->ibdev_fn) !=   \
> -			    sizeof(void *)),                                   \
> +			BUILD_BUG_ON_ZERO(sizeof_field(struct ib_device_ops,   \
> +						       ibdev_fn) !=            \
> +					  sizeof(void *)),                     \
>  	}
>  
>  /* Call a function to determine if the entire object is supported or not */

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ