lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 27 May 2020 15:31:09 +0530
From:   Sumit Garg <sumit.garg@...aro.org>
To:     Daniel Thompson <daniel.thompson@...aro.org>
Cc:     kgdb-bugreport@...ts.sourceforge.net,
        Jason Wessel <jason.wessel@...driver.com>,
        Douglas Anderson <dianders@...omium.org>,
        Petr Mladek <pmladek@...e.com>,
        Sergey Senozhatsky <sergey.senozhatsky@...il.com>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v3 1/4] kdb: Re-factor kdb_printf() message write code

On Wed, 27 May 2020 at 13:59, Daniel Thompson
<daniel.thompson@...aro.org> wrote:
>
> On Wed, May 27, 2020 at 11:55:56AM +0530, Sumit Garg wrote:
> > Re-factor kdb_printf() message write code in order to avoid duplication
> > of code and thereby increase readability.
> >
> > Signed-off-by: Sumit Garg <sumit.garg@...aro.org>
> > ---
> >  kernel/debug/kdb/kdb_io.c | 61 +++++++++++++++++++++++++----------------------
> >  1 file changed, 32 insertions(+), 29 deletions(-)
> >
> > diff --git a/kernel/debug/kdb/kdb_io.c b/kernel/debug/kdb/kdb_io.c
> > index 924bc92..f6b4d47 100644
> > --- a/kernel/debug/kdb/kdb_io.c
> > +++ b/kernel/debug/kdb/kdb_io.c
> > @@ -542,6 +542,33 @@ static int kdb_search_string(char *searched, char *searchfor)
> >       return 0;
> >  }
> >
> > +static void kdb_io_write(char *cp, int len, void (*io_put_char)(u8 ch))
>
> Don't use a function pointer here. Just pick it up from dbg_io_ops as
> usual.

My initial intent to use function pointer here was to extend this API
in patch #4 for poll_put_char() as well. But it just came to my mind
after your comment that internally dbg_io_ops->write_char() fallbacks
to tty_drv->ops->poll_put_char() API only. So I don't need to do any
crazy things with function pointers here in order to avoid a duplicate
loop but can simply invoke dbg_io_ops->write_char() here instead.

>
> > +{
> > +     if (len <= 0)
> > +             return;
>
> How can len ever be negative?
>

The only rationale to have this check is for completeness as the type
of variable: "len" being "int". If you don't prefer such checks, then
I can replace it with an "==" check.

>
> > +
> > +     while (len--) {
> > +             io_put_char(*cp);
> > +             cp++;
> > +     }
> > +}
> > +
> > +static void kdb_msg_write(char *msg, int msg_len)
> > +{
> > +     struct console *c;
> > +
> > +     if (msg_len <= 0)
> > +             return;
>
> How can msg_len ever be negative?
>

Same as above.

-Sumit

>
> > +
> > +     if (dbg_io_ops && !dbg_io_ops->is_console)
> > +             kdb_io_write(msg, msg_len, dbg_io_ops->write_char);
> > +
> > +     for_each_console(c) {
> > +             c->write(c, msg, msg_len);
> > +             touch_nmi_watchdog();
> > +     }
> > +}
> > +
> >  int vkdb_printf(enum kdb_msgsrc src, const char *fmt, va_list ap)
> >  {
> >       int diag;
> > @@ -553,7 +580,6 @@ int vkdb_printf(enum kdb_msgsrc src, const char *fmt, va_list ap)
> >       int this_cpu, old_cpu;
> >       char *cp, *cp2, *cphold = NULL, replaced_byte = ' ';
> >       char *moreprompt = "more> ";
> > -     struct console *c;
> >       unsigned long uninitialized_var(flags);
> >
> >       /* Serialize kdb_printf if multiple cpus try to write at once.
> > @@ -687,22 +713,11 @@ int vkdb_printf(enum kdb_msgsrc src, const char *fmt, va_list ap)
> >        */
> >       retlen = strlen(kdb_buffer);
> >       cp = (char *) printk_skip_headers(kdb_buffer);
> > -     if (!dbg_kdb_mode && kgdb_connected) {
> > +     if (!dbg_kdb_mode && kgdb_connected)
> >               gdbstub_msg_write(cp, retlen - (cp - kdb_buffer));
> > -     } else {
> > -             if (dbg_io_ops && !dbg_io_ops->is_console) {
> > -                     len = retlen - (cp - kdb_buffer);
> > -                     cp2 = cp;
> > -                     while (len--) {
> > -                             dbg_io_ops->write_char(*cp2);
> > -                             cp2++;
> > -                     }
> > -             }
> > -             for_each_console(c) {
> > -                     c->write(c, cp, retlen - (cp - kdb_buffer));
> > -                     touch_nmi_watchdog();
> > -             }
> > -     }
> > +     else
> > +             kdb_msg_write(cp, retlen - (cp - kdb_buffer));
> > +
> >       if (logging) {
> >               saved_loglevel = console_loglevel;
> >               console_loglevel = CONSOLE_LOGLEVEL_SILENT;
> > @@ -751,19 +766,7 @@ int vkdb_printf(enum kdb_msgsrc src, const char *fmt, va_list ap)
> >                       moreprompt = "more> ";
> >
> >               kdb_input_flush();
> > -
> > -             if (dbg_io_ops && !dbg_io_ops->is_console) {
> > -                     len = strlen(moreprompt);
> > -                     cp = moreprompt;
> > -                     while (len--) {
> > -                             dbg_io_ops->write_char(*cp);
> > -                             cp++;
> > -                     }
> > -             }
> > -             for_each_console(c) {
> > -                     c->write(c, moreprompt, strlen(moreprompt));
> > -                     touch_nmi_watchdog();
> > -             }
> > +             kdb_msg_write(moreprompt, strlen(moreprompt));
> >
> >               if (logging)
> >                       printk("%s", moreprompt);
> > --
> > 2.7.4
> >

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ