lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 27 May 2020 15:35:38 +0200
From:   Arnd Bergmann <arnd@...db.de>
To:     Georgi Djakov <georgi.djakov@...aro.org>,
        Rob Clark <robdclark@...omium.org>,
        Kalyan Thota <kalyan_t@...eaurora.org>
Cc:     Arnd Bergmann <arnd@...db.de>,
        Matthias Kaehlcke <mka@...omium.org>,
        Sibi Sankar <sibis@...eaurora.org>,
        Viresh Kumar <viresh.kumar@...aro.org>,
        Evan Green <evgreen@...omium.org>,
        Akash Asthana <akashast@...eaurora.org>,
        linux-pm@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [PATCH] drm/msm/dpu: avoid open-coded 64-bit division

64-bit integer division is normally not allowed in the kernel
because of the large overhead on 32-bit machines:

drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.o: in function `_dpu_core_perf_crtc_update_bus':
dpu_core_perf.c:(.text+0x810): undefined reference to `__aeabi_uldivmod'

The function already contains a call to do_div(), so I assume this
is never called in a performance critical context, and we can
use div_u64 for the second one as well.

Fixes: 04d9044f6c57 ("drm/msm/dpu: add support for clk and bw scaling for display")
Signed-off-by: Arnd Bergmann <arnd@...db.de>
---
 include/linux/interconnect.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/linux/interconnect.h b/include/linux/interconnect.h
index 3a63d98613fc..8279fe9b2082 100644
--- a/include/linux/interconnect.h
+++ b/include/linux/interconnect.h
@@ -11,7 +11,7 @@
 #include <linux/types.h>
 
 /* macros for converting to icc units */
-#define Bps_to_icc(x)	((x) / 1000)
+#define Bps_to_icc(x)	div_u64((x), 1000)
 #define kBps_to_icc(x)	(x)
 #define MBps_to_icc(x)	((x) * 1000)
 #define GBps_to_icc(x)	((x) * 1000 * 1000)
-- 
2.26.2

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ