lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 28 May 2020 15:41:07 +0100
From:   Lorenzo Pieralisi <lorenzo.pieralisi@....com>
To:     "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc:     "K. Y. Srinivasan" <kys@...rosoft.com>,
        Haiyang Zhang <haiyangz@...rosoft.com>,
        Stephen Hemminger <sthemmin@...rosoft.com>,
        Wei Liu <wei.liu@...nel.org>, Rob Herring <robh@...nel.org>,
        Bjorn Helgaas <bhelgaas@...gle.com>,
        linux-hyperv@...r.kernel.org, linux-pci@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        "Gustavo A. R. Silva" <gustavo@...eddedor.com>,
        Kees Cook <keescook@...omium.org>
Subject: Re: [PATCH] PCI: hv: Use struct_size() helper

On Mon, May 25, 2020 at 11:43:19AM -0500, Gustavo A. R. Silva wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct hv_dr_state {
> 	...
>         struct hv_pcidev_description func[];
> };
> 
> struct pci_bus_relations {
> 	...
>         struct pci_function_description func[];
> } __packed;
> 
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> So, replace the following forms:
> 
> offsetof(struct hv_dr_state, func) +
> 	(sizeof(struct hv_pcidev_description) *
> 	(relations->device_count))
> 
> offsetof(struct pci_bus_relations, func) +
> 	(sizeof(struct pci_function_description) *
> 	(bus_rel->device_count))
> 
> with:
> 
> struct_size(dr, func, relations->device_count)
> 
> and
> 
> struct_size(bus_rel, func, bus_rel->device_count)
> 
> respectively.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> ---
>  drivers/pci/controller/pci-hyperv.c | 22 ++++++++--------------
>  1 file changed, 8 insertions(+), 14 deletions(-)

Applied to pci/hv, thanks.

Lorenzo

> diff --git a/drivers/pci/controller/pci-hyperv.c b/drivers/pci/controller/pci-hyperv.c
> index 892f3a742117a..bf40ff09c99d6 100644
> --- a/drivers/pci/controller/pci-hyperv.c
> +++ b/drivers/pci/controller/pci-hyperv.c
> @@ -2213,10 +2213,8 @@ static void hv_pci_devices_present(struct hv_pcibus_device *hbus,
>  	struct hv_dr_state *dr;
>  	int i;
>  
> -	dr = kzalloc(offsetof(struct hv_dr_state, func) +
> -		     (sizeof(struct hv_pcidev_description) *
> -		      (relations->device_count)), GFP_NOWAIT);
> -
> +	dr = kzalloc(struct_size(dr, func, relations->device_count),
> +		     GFP_NOWAIT);
>  	if (!dr)
>  		return;
>  
> @@ -2250,10 +2248,8 @@ static void hv_pci_devices_present2(struct hv_pcibus_device *hbus,
>  	struct hv_dr_state *dr;
>  	int i;
>  
> -	dr = kzalloc(offsetof(struct hv_dr_state, func) +
> -		     (sizeof(struct hv_pcidev_description) *
> -		      (relations->device_count)), GFP_NOWAIT);
> -
> +	dr = kzalloc(struct_size(dr, func, relations->device_count),
> +		     GFP_NOWAIT);
>  	if (!dr)
>  		return;
>  
> @@ -2447,9 +2443,8 @@ static void hv_pci_onchannelcallback(void *context)
>  
>  				bus_rel = (struct pci_bus_relations *)buffer;
>  				if (bytes_recvd <
> -				    offsetof(struct pci_bus_relations, func) +
> -				    (sizeof(struct pci_function_description) *
> -				     (bus_rel->device_count))) {
> +					struct_size(bus_rel, func,
> +						    bus_rel->device_count)) {
>  					dev_err(&hbus->hdev->device,
>  						"bus relations too small\n");
>  					break;
> @@ -2462,9 +2457,8 @@ static void hv_pci_onchannelcallback(void *context)
>  
>  				bus_rel2 = (struct pci_bus_relations2 *)buffer;
>  				if (bytes_recvd <
> -				    offsetof(struct pci_bus_relations2, func) +
> -				    (sizeof(struct pci_function_description2) *
> -				     (bus_rel2->device_count))) {
> +					struct_size(bus_rel2, func,
> +						    bus_rel2->device_count)) {
>  					dev_err(&hbus->hdev->device,
>  						"bus relations v2 too small\n");
>  					break;
> -- 
> 2.26.2
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ