[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200618103506.GH576905@hirez.programming.kicks-ass.net>
Date: Thu, 18 Jun 2020 12:35:06 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: David Hildenbrand <david@...hat.com>
Cc: Christoph Hellwig <hch@....de>,
Andrew Morton <akpm@...ux-foundation.org>,
Dexuan Cui <decui@...rosoft.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>, Jessica Yu <jeyu@...nel.org>,
x86@...nel.org, linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org, linux-hyperv@...r.kernel.org,
linux-mm@...ck.org
Subject: Re: [PATCH 2/3] arm64: use PAGE_KERNEL_ROX directly in
alloc_insn_page
On Thu, Jun 18, 2020 at 10:55:58AM +0200, David Hildenbrand wrote:
> On 18.06.20 08:43, Christoph Hellwig wrote:
> > Use PAGE_KERNEL_ROX directly instead of allocating RWX and setting the
> > page read-only just after the allocation.
> >
> > Signed-off-by: Christoph Hellwig <hch@....de>
> > ---
> > arch/arm64/kernel/probes/kprobes.c | 12 +++---------
> > 1 file changed, 3 insertions(+), 9 deletions(-)
> >
> > diff --git a/arch/arm64/kernel/probes/kprobes.c b/arch/arm64/kernel/probes/kprobes.c
> > index d1c95dcf1d7833..cbe49cd117cfec 100644
> > --- a/arch/arm64/kernel/probes/kprobes.c
> > +++ b/arch/arm64/kernel/probes/kprobes.c
> > @@ -120,15 +120,9 @@ int __kprobes arch_prepare_kprobe(struct kprobe *p)
> >
> > void *alloc_insn_page(void)
> > {
> > - void *page;
> > -
> > - page = vmalloc_exec(PAGE_SIZE);
> > - if (page) {
> > - set_memory_ro((unsigned long)page, 1);
> > - set_vm_flush_reset_perms(page);
> > - }
> > -
> > - return page;
> > + return __vmalloc_node_range(PAGE_SIZE, 1, VMALLOC_START, VMALLOC_END,
> > + GFP_KERNEL, PAGE_KERNEL_ROX, VM_FLUSH_RESET_PERMS,
> > + NUMA_NO_NODE, __func__);
>
> I do wonder if something like vmalloc_prot(size, prot) would make this
> (and the other two users) easier to read.
>
> So instead of ripping out vmalloc_exec(), converting it into
> vmalloc_prot() instead.
>
> Did you consider that?
For x86 Christoph did module_alloc_prot(), which is in his more
extensive set of patches addressing this. I suspect that would be the
right thing for ARM64 as well.
Powered by blists - more mailing lists