[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87r1u5laac.fsf@x220.int.ebiederm.org>
Date: Tue, 23 Jun 2020 16:52:43 -0500
From: ebiederm@...ssion.com (Eric W. Biederman)
To: <linux-kernel@...r.kernel.org>
Cc: <linux-fsdevel@...r.kernel.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Oleg Nesterov <oleg@...hat.com>, Jann Horn <jannh@...gle.com>,
Kees Cook <keescook@...omium.org>,
Bernd Edlinger <bernd.edlinger@...mail.de>
Subject: [PATCH v2 0/6] exec: s/group_exit_task/group_exec_task/ for clarity
There is a variable tsk->signal->group_exit_task that is only truly used
in de_thread. These changes modify the coredump code and the
signal_group_exit() function to stop using group_exit_task, and rename
the group_exit_task variable to group_exec_task.
In addition as I think Linus was asking an additional signal flag is
added called SIGNAL_GROUP_DETHREAD, and that flag is used in the
function signal_group_exit() so that only signal->flags needs to be
tested.
Eric W. Biederman (6):
signal: Pretty up the SIGNAL_GROUP_FLAGS
exec: Lock more defensively in exec
signal: Implement SIGNAL_GROUP_DETHREAD
signal: In signal_group_exit remove the group_exit_task test
coredump: Stop using group_exit_task
exec: Rename group_exit_task group_exec_task and correct the Documentation
fs/coredump.c | 2 --
fs/exec.c | 22 ++++++++++++++++------
include/linux/sched/signal.h | 33 +++++++++++++++++----------------
kernel/exit.c | 4 ++--
4 files changed, 35 insertions(+), 26 deletions(-)
Powered by blists - more mailing lists