[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <877dvxggsl.fsf@collabora.com>
Date: Wed, 24 Jun 2020 01:43:22 -0400
From: Gabriel Krisman Bertazi <krisman@...labora.com>
To: Daniel Rosenberg <drosen@...gle.com>
Cc: "Theodore Ts'o" <tytso@....edu>, linux-ext4@...r.kernel.org,
Jaegeuk Kim <jaegeuk@...nel.org>, Chao Yu <chao@...nel.org>,
linux-f2fs-devel@...ts.sourceforge.net,
Eric Biggers <ebiggers@...nel.org>,
linux-fscrypt@...r.kernel.org,
Alexander Viro <viro@...iv.linux.org.uk>,
Richard Weinberger <richard@....at>,
linux-mtd@...ts.infradead.org,
Andreas Dilger <adilger.kernel@...ger.ca>,
Jonathan Corbet <corbet@....net>, linux-doc@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org,
kernel-team@...roid.com
Subject: Re: [PATCH v9 4/4] ext4: Use generic casefolding support
Daniel Rosenberg <drosen@...gle.com> writes:
> -
> const struct dentry_operations ext4_dentry_ops = {
> - .d_hash = ext4_d_hash,
> - .d_compare = ext4_d_compare,
> + .d_hash = generic_ci_d_hash,
> + .d_compare = generic_ci_d_compare,
> };
> #endif
Can you make the structure generic since it is the same for f2fs and
ext4, which let you drop the code guards? Unless that becomes a problem for
d_revalidate with fscrypt, it is fine like this.
> #ifdef CONFIG_UNICODE
> - sbi = EXT4_SB(sb);
> - if (ext4_has_strict_mode(sbi) && IS_CASEFOLDED(dir) &&
> - sbi->s_encoding && utf8_validate(sbi->s_encoding, &dentry->d_name))
> + if (sb_has_enc_strict_mode(sb) && IS_CASEFOLDED(dir) &&
I keep reading the 'enc' in sb_has_enc_strict_mode() as 'encryption'. What do
you think about renaming it to sb_has_strict_encoding()?
These comments apply equally to patches 3 and 4. Other than that,
Reviewed-by: Gabriel Krisman Bertazi <krisman@...labora.com>
--
Gabriel Krisman Bertazi
Powered by blists - more mailing lists