[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <440d84877c3bc0917790466ee85753919fb29cb5.1592980985.git.baolin.wang@linux.alibaba.com>
Date: Wed, 24 Jun 2020 14:49:58 +0800
From: Baolin Wang <baolin.wang@...ux.alibaba.com>
To: kbusch@...nel.org, axboe@...com, hch@....de, sagi@...mberg.me
Cc: baolin.wang@...ux.alibaba.com, baolin.wang7@...il.com,
linux-nvme@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: [PATCH v2 2/2] nvme: Use USEC_PER_SEC instead of magic numbers
Use USEC_PER_SEC instead of magic numbers to make code more readable.
Reviewed-by: Sagi Grimberg <sagi@...mberg.me>
Signed-off-by: Baolin Wang <baolin.wang@...ux.alibaba.com>
---
drivers/nvme/host/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index f5f882f..405bafa 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -2967,7 +2967,7 @@ int nvme_init_identify(struct nvme_ctrl *ctrl)
if (id->rtd3e) {
/* us -> s */
- u32 transition_time = le32_to_cpu(id->rtd3e) / 1000000;
+ u32 transition_time = le32_to_cpu(id->rtd3e) / USEC_PER_SEC;
ctrl->shutdown_timeout = clamp_t(unsigned int, transition_time,
shutdown_timeout, 60);
--
1.8.3.1
Powered by blists - more mailing lists