[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200626135216.24314-2-richard.weiyang@linux.alibaba.com>
Date: Fri, 26 Jun 2020 21:52:13 +0800
From: Wei Yang <richard.weiyang@...ux.alibaba.com>
To: akpm@...ux-foundation.org, kirill.shutemov@...ux.intel.com,
yang.shi@...ux.alibaba.com, vbabka@...e.cz, willy@...radead.org,
thomas_os@...pmail.org, thellstrom@...are.com,
anshuman.khandual@....com, sean.j.christopherson@...el.com,
aneesh.kumar@...ux.ibm.com, peterx@...hat.com, walken@...gle.com
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org, digetx@...il.com,
Wei Yang <richard.weiyang@...ux.alibaba.com>
Subject: [RESEND Patch v2 1/4] mm/mremap: format the check in move_normal_pmd() same as move_huge_pmd()
No functional change, just improve the readability and prepare for
following cleanup.
Signed-off-by: Wei Yang <richard.weiyang@...ux.alibaba.com>
Tested-by: Dmitry Osipenko <digetx@...il.com>
---
mm/mremap.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/mm/mremap.c b/mm/mremap.c
index 5dd572d57ca9..97bf9a2a8bd5 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -200,8 +200,9 @@ static bool move_normal_pmd(struct vm_area_struct *vma, unsigned long old_addr,
struct mm_struct *mm = vma->vm_mm;
pmd_t pmd;
- if ((old_addr & ~PMD_MASK) || (new_addr & ~PMD_MASK)
- || old_end - old_addr < PMD_SIZE)
+ if ((old_addr & ~PMD_MASK) ||
+ (new_addr & ~PMD_MASK) ||
+ old_end - old_addr < PMD_SIZE)
return false;
/*
--
2.20.1 (Apple Git-117)
Powered by blists - more mailing lists