[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200626165535.7662-1-brgl@bgdev.pl>
Date: Fri, 26 Jun 2020 18:55:30 +0200
From: Bartosz Golaszewski <brgl@...ev.pl>
To: Jonathan Corbet <corbet@....net>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J . Wysocki" <rafael@...nel.org>,
Guenter Roeck <linux@...ck-us.net>,
Jean Delvare <jdelvare@...e.com>
Cc: linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-hwmon@...r.kernel.org,
Bartosz Golaszewski <bgolaszewski@...libre.com>
Subject: [PATCH 0/5] devres: provide and use devm_krealloc()
From: Bartosz Golaszewski <bgolaszewski@...libre.com>
Regular krealloc() obviously can't work with managed memory. This series
implements devm_krealloc() and adds the first user with hope that this
helper will be adopted by other drivers currently using non-managed
krealloc().
Some cosmetic changes to the code modified by main patches are included.
Bartosz Golaszewski (5):
devres: remove stray space from devm_kmalloc() definition
devres: move the size check from alloc_dr() into a separate function
device: remove 'extern' attribute from function prototypes in device.h
devres: provide devm_krealloc()
hwmon: pmbus: use more devres helpers
.../driver-api/driver-model/devres.rst | 1 +
drivers/base/devres.c | 58 ++++-
drivers/hwmon/pmbus/pmbus_core.c | 27 +--
include/linux/device.h | 225 +++++++++---------
4 files changed, 173 insertions(+), 138 deletions(-)
--
2.26.1
Powered by blists - more mailing lists