[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200629112242.18380-1-a.hajda@samsung.com>
Date: Mon, 29 Jun 2020 13:22:38 +0200
From: Andrzej Hajda <a.hajda@...sung.com>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: Andrzej Hajda <a.hajda@...sung.com>,
Bartlomiej Zolnierkiewicz <b.zolnierkie@...sung.com>,
Marek Szyprowski <m.szyprowski@...sung.com>,
"Rafael J. Wysocki" <rafael@...nel.org>,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
andy.shevchenko@...il.com, Mark Brown <broonie@...nel.org>,
Russell King - ARM Linux <linux@...linux.org.uk>,
Neil Armstrong <narmstrong@...libre.com>,
Laurent Pinchart <Laurent.pinchart@...asonboard.com>,
Jonas Karlman <jonas@...boo.se>,
Jernej Skrabec <jernej.skrabec@...l.net>,
Daniel Vetter <daniel@...ll.ch>,
dri-devel@...ts.freedesktop.org (open list:DRM DRIVERS)
Subject: [PATCH v7 0/4] driver core: add probe error check helper
Hi All,
Thanks for comments.
Changes since v6:
- removed leftovers from old naming scheme in commit descritions,
- added R-Bs.
Changes since v5:
- removed patch adding macro, dev_err_probe(dev, PTR_ERR(ptr), ...) should be used instead,
- added dev_dbg logging in case of -EPROBE_DEFER,
- renamed functions and vars according to comments,
- extended docs,
- cosmetics.
Original message (with small adjustments):
Recently I took some time to re-check error handling in drivers probe code,
and I have noticed that number of incorrect resource acquisition error handling
increased and there are no other propositions which can cure the situation.
So I have decided to resend my old proposition of probe_err helper which should
simplify resource acquisition error handling, it also extend it with adding defer
probe reason to devices_deferred debugfs property, which should improve debugging
experience for developers/testers.
I have also added two patches showing usage and benefits of the helper.
My dirty/ad-hoc cocci scripts shows that this helper can be used in at least 2700 places
saving about 3500 lines of code.
Regards
Andrzej
Andrzej Hajda (4):
driver core: add device probe log helper
driver core: add deferring probe reason to devices_deferred property
drm/bridge/sii8620: fix resource acquisition error handling
drm/bridge: lvds-codec: simplify error handling
drivers/base/base.h | 3 ++
drivers/base/core.c | 46 ++++++++++++++++++++++++++++
drivers/base/dd.c | 23 +++++++++++++-
drivers/gpu/drm/bridge/lvds-codec.c | 10 ++----
drivers/gpu/drm/bridge/sil-sii8620.c | 21 ++++++-------
include/linux/device.h | 3 ++
6 files changed, 86 insertions(+), 20 deletions(-)
--
2.17.1
Powered by blists - more mailing lists