[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200630212517.308045-2-ben.widawsky@intel.com>
Date: Tue, 30 Jun 2020 14:25:06 -0700
From: Ben Widawsky <ben.widawsky@...el.com>
To: linux-mm <linux-mm@...ck.org>, linux-kernel@...r.kernel.org
Cc: Michal Hocko <mhocko@...nel.org>,
Dave Hansen <dave.hansen@...el.com>,
Ben Widawsky <ben.widawsky@...el.com>,
Andrew Morton <akpm@...ux-foundation.org>,
David Rientjes <rientjes@...gle.com>,
Michal Hocko <mhocko@...e.com>
Subject: [PATCH 01/12] mm/mempolicy: Add comment for missing LOCAL
MPOL_LOCAL is a bit weird because it is simply a different name for an
existing behavior (preferred policy with no node mask). It has been this
way since it was added here:
commit 479e2802d09f ("mm: mempolicy: Make MPOL_LOCAL a real policy")
It is so similar to MPOL_PREFERRED in fact that when the policy is
created in mpol_new, the mode is set as PREFERRED, and an internal state
representing LOCAL doesn't exist.
To prevent future explorers from scratching their head as to why
MPOL_LOCAL isn't defined in the mpol_ops table, add a small comment
explaining the situations.
v2:
Change comment to refer to mpol_new (Michal)
Cc: Andrew Morton <akpm@...ux-foundation.org>
Cc: David Rientjes <rientjes@...gle.com>
Acked-by: Michal Hocko <mhocko@...e.com>
Signed-off-by: Ben Widawsky <ben.widawsky@...el.com>
---
mm/mempolicy.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/mm/mempolicy.c b/mm/mempolicy.c
index 381320671677..bde193278301 100644
--- a/mm/mempolicy.c
+++ b/mm/mempolicy.c
@@ -427,6 +427,7 @@ static const struct mempolicy_operations mpol_ops[MPOL_MAX] = {
.create = mpol_new_bind,
.rebind = mpol_rebind_nodemask,
},
+ /* [MPOL_LOCAL] - see mpol_new() */
};
static int migrate_page_add(struct page *page, struct list_head *pagelist,
--
2.27.0
Powered by blists - more mailing lists