lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 30 Jun 2020 09:58:47 -0700
From:   Linus Torvalds <>
To:     "Eric W. Biederman" <>
Cc:     Linux Kernel Mailing List <>,
        David Miller <>,
        Greg Kroah-Hartman <>,
        Tetsuo Handa <>,
        Alexei Starovoitov <>,
        Kees Cook <>,
        Andrew Morton <>,
        Alexei Starovoitov <>,
        Al Viro <>, bpf <>,
        linux-fsdevel <>,
        Daniel Borkmann <>,
        Jakub Kicinski <>,
        Masahiro Yamada <>,
        Gary Lin <>, Bruno Meneguele <>,
        LSM List <>,
        Casey Schaufler <>,
        Luis Chamberlain <>
Subject: Re: [PATCH v2 05/15] umh: Separate the user mode driver and the user
 mode helper support

On Mon, Jun 29, 2020 at 1:05 PM Eric W. Biederman <> wrote:
> This makes it clear which code is part of the core user mode
> helper support and which code is needed to implement user mode
> drivers.
>  kernel/umd.c             | 146 +++++++++++++++++++++++++++++++++++++++
>  kernel/umh.c             | 139 -------------------------------------

I certainly don't object to the split, but I hate the name.

We have uml, umd and umh for user mode {linux, drivers, helper}
respectively.And honestly, I don't see the point in using an obscure
and unreadable TLA for something like this.

I really don't think it would hurt to write out even the full name
with "usermode_driver.c" or something like that, would it?

Then "umd" could be continued to be used as a prefix for the helper
functions, by all means, but if we startv renaming files, can we do it


Powered by blists - more mailing lists