[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200701114212.8520-1-geert+renesas@glider.be>
Date: Wed, 1 Jul 2020 13:42:10 +0200
From: Geert Uytterhoeven <geert+renesas@...der.be>
To: Linus Walleij <linus.walleij@...aro.org>,
Bartosz Golaszewski <bgolaszewski@...libre.com>,
Andy Shevchenko <andy.shevchenko@...il.com>
Cc: linux-gpio@...r.kernel.org, linux-renesas-soc@...r.kernel.org,
linux-kernel@...r.kernel.org,
Geert Uytterhoeven <geert+renesas@...der.be>
Subject: [PATCH v2 0/2] gpio: aggregator: Misc parsing improvements
Hi Linus, Bartosz, Andy,
This patch series contains two improvements for the parsing code in the
GPIO Aggregator.
The second one converts the driver to use bitmap_parselist() for parsing
GPIO offsets and/or ranges, as suggested by Andy[1]. This should have
no impact on the format of the configuration parameters written to the
"new_device" virtual file in sysfs.
Changes compared to v1:
- Rename mask to bitmap,
- Allocate bitmap dynamically.
Thanks for your comments!
[1] https://lore.kernel.org/r/20200520121420.GA1867563@smile.fi.intel.com
Geert Uytterhoeven (2):
gpio: aggregator: Drop pre-initialization in get_arg()
gpio: aggregator: Use bitmap_parselist() for parsing GPIO offsets
drivers/gpio/gpio-aggregator.c | 63 +++++++++++++++-------------------
1 file changed, 28 insertions(+), 35 deletions(-)
--
2.17.1
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Powered by blists - more mailing lists