[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1693d7a8-4384-8fd8-69a2-55552329a34d@suse.cz>
Date: Fri, 3 Jul 2020 17:56:29 +0200
From: Vlastimil Babka <vbabka@...e.cz>
To: js1304@...il.com, Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org,
kernel-team@....com, Christoph Hellwig <hch@...radead.org>,
Roman Gushchin <guro@...com>,
Mike Kravetz <mike.kravetz@...cle.com>,
Naoya Horiguchi <n-horiguchi@...jp.nec.com>,
Michal Hocko <mhocko@...e.com>,
Joonsoo Kim <iamjoonsoo.kim@....com>
Subject: Re: [PATCH v3 6/8] mm/gup: use a standard migration target allocation
callback
On 6/23/20 8:13 AM, js1304@...il.com wrote:
> From: Joonsoo Kim <iamjoonsoo.kim@....com>
>
> There is a well-defined migration target allocation callback.
> It's mostly similar with new_non_cma_page() except considering CMA pages.
>
> This patch adds a CMA consideration to the standard migration target
> allocation callback and use it on gup.c.
>
> Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@....com>
Acked-by: Vlastimil Babka <vbabka@...e.cz>
But a suggestion below.
> ---
> mm/gup.c | 57 ++++++++-------------------------------------------------
> mm/internal.h | 1 +
> mm/migrate.c | 4 +++-
> 3 files changed, 12 insertions(+), 50 deletions(-)
>
> diff --git a/mm/gup.c b/mm/gup.c
> index 15be281..f6124e3 100644
> --- a/mm/gup.c
> +++ b/mm/gup.c
> @@ -1608,56 +1608,15 @@ static bool check_dax_vmas(struct vm_area_struct **vmas, long nr_pages)
> }
>
> #ifdef CONFIG_CMA
> -static struct page *new_non_cma_page(struct page *page, unsigned long private)
> +static struct page *alloc_migration_target_non_cma(struct page *page, unsigned long private)
> {
...
> + struct migration_target_control mtc = {
> + .nid = page_to_nid(page),
> + .gfp_mask = GFP_USER | __GFP_NOWARN,
> + .skip_cma = true,
> + };
>
> - return __alloc_pages_node(nid, gfp_mask, 0);
> + return alloc_migration_target(page, (unsigned long)&mtc);
Do we really need this wrapper? The only user is check_and_migrate_cma_pages so
just opencode it?
Powered by blists - more mailing lists