lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <47a86753-fd4d-9a7a-c808-5f387c872ab3@linux.ibm.com>
Date:   Wed, 8 Jul 2020 11:13:08 +0200
From:   Stefan Haberland <sth@...ux.ibm.com>
To:     "Gustavo A. R. Silva" <gustavoars@...nel.org>,
        Jan Hoeppner <hoeppner@...ux.ibm.com>,
        Heiko Carstens <heiko.carstens@...ibm.com>,
        Vasily Gorbik <gor@...ux.ibm.com>,
        Christian Borntraeger <borntraeger@...ibm.com>
Cc:     linux-s390@...r.kernel.org, linux-kernel@...r.kernel.org,
        "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] s390/dasd: Use struct_size() helper

Am 19.06.20 um 18:56 schrieb Gustavo A. R. Silva:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes. Also, remove unnecessary
> variable _datasize_.
>
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
>
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>

Thanks for the patch.
Tested and applied.

> ---
>  drivers/s390/block/dasd_diag.c | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/s390/block/dasd_diag.c b/drivers/s390/block/dasd_diag.c
> index facb588d09e4..7f53ba015300 100644
> --- a/drivers/s390/block/dasd_diag.c
> +++ b/drivers/s390/block/dasd_diag.c
> @@ -506,7 +506,7 @@ static struct dasd_ccw_req *dasd_diag_build_cp(struct dasd_device *memdev,
>  	struct req_iterator iter;
>  	struct bio_vec bv;
>  	char *dst;
> -	unsigned int count, datasize;
> +	unsigned int count;
>  	sector_t recid, first_rec, last_rec;
>  	unsigned int blksize, off;
>  	unsigned char rw_cmd;
> @@ -534,10 +534,8 @@ static struct dasd_ccw_req *dasd_diag_build_cp(struct dasd_device *memdev,
>  	if (count != last_rec - first_rec + 1)
>  		return ERR_PTR(-EINVAL);
>  	/* Build the request */
> -	datasize = sizeof(struct dasd_diag_req) +
> -		count*sizeof(struct dasd_diag_bio);
> -	cqr = dasd_smalloc_request(DASD_DIAG_MAGIC, 0, datasize, memdev,
> -				   blk_mq_rq_to_pdu(req));
> +	cqr = dasd_smalloc_request(DASD_DIAG_MAGIC, 0, struct_size(dreq, bio, count),
> +				   memdev, blk_mq_rq_to_pdu(req));
>  	if (IS_ERR(cqr))
>  		return cqr;
>  

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ