[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200709210527.GA17678@bjorn-Precision-5520>
Date: Thu, 9 Jul 2020 16:05:27 -0500
From: Bjorn Helgaas <helgaas@...nel.org>
To: Yi Wang <wang.yi59@....com.cn>
Cc: bhelgaas@...gle.com, linux-pci@...r.kernel.org,
linux-kernel@...r.kernel.org, xue.zhihong@....com.cn,
wang.liang82@....com.cn, Liao Pingfang <liao.pingfang@....com.cn>
Subject: Re: [PATCH] PCI: Replace kmalloc with kzalloc in the comment/message
On Thu, Jul 09, 2020 at 03:28:28PM +0800, Yi Wang wrote:
> From: Liao Pingfang <liao.pingfang@....com.cn>
>
> Use kzalloc instead of kmalloc in the comment/message according to
> the previous kzalloc() call.
>
> Signed-off-by: Liao Pingfang <liao.pingfang@....com.cn>
> Signed-off-by: Yi Wang <wang.yi59@....com.cn>
I applied the setup-bus.c change to pci/misc for v5.9, thanks!
I dropped the ibmphp_pci.c comment change because (a) it's not clear
the comment is correct even after the change, and (b) that file is so
out-of-date and hard to read that I don't want to touch it unless
we're really fixing something significant.
> ---
> drivers/pci/hotplug/ibmphp_pci.c | 2 +-
> drivers/pci/setup-bus.c | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/pci/hotplug/ibmphp_pci.c b/drivers/pci/hotplug/ibmphp_pci.c
> index e22d023..2d36992 100644
> --- a/drivers/pci/hotplug/ibmphp_pci.c
> +++ b/drivers/pci/hotplug/ibmphp_pci.c
> @@ -205,7 +205,7 @@ int ibmphp_configure_card(struct pci_func *func, u8 slotno)
> cur_func->next = newfunc;
>
> rc = ibmphp_configure_card(newfunc, slotno);
> - /* This could only happen if kmalloc failed */
> + /* This could only happen if kzalloc failed */
> if (rc) {
> /* We need to do this in case bridge itself got configured properly, but devices behind it failed */
> func->bus = 1; /* To indicate to the unconfigure function that this is a PPB */
> diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
> index bbcef1a..13c5a44 100644
> --- a/drivers/pci/setup-bus.c
> +++ b/drivers/pci/setup-bus.c
> @@ -151,7 +151,7 @@ static void pdev_sort_resources(struct pci_dev *dev, struct list_head *head)
>
> tmp = kzalloc(sizeof(*tmp), GFP_KERNEL);
> if (!tmp)
> - panic("pdev_sort_resources(): kmalloc() failed!\n");
> + panic("%s: kzalloc() failed!\n", __func__);
> tmp->res = r;
> tmp->dev = dev;
>
> --
> 2.9.5
>
Powered by blists - more mailing lists