[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200714054137.GA49448@f3>
Date: Tue, 14 Jul 2020 14:41:37 +0900
From: Benjamin Poirier <benjamin.poirier@...il.com>
To: Suraj Upadhyay <usuraj35@...il.com>
Cc: manishc@...vell.com, GR-Linux-NIC-Dev@...vell.com,
gregkh@...uxfoundation.org, netdev@...r.kernel.org,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/6] staging: qlge: qlge_main: Simplify while statements.
On 2020-07-13 17:50 +0530, Suraj Upadhyay wrote:
> Simplify while loops into more readable and simple for loops.
>
> Signed-off-by: Suraj Upadhyay <usuraj35@...il.com>
> ---
[...]
> @@ -1824,7 +1821,7 @@ static struct sk_buff *ql_build_rx_skb(struct ql_adapter *qdev,
> sbq_desc->p.skb = NULL;
> skb_reserve(skb, NET_IP_ALIGN);
> }
> - do {
> + for (; length > 0; length -= size, i++) {
> lbq_desc = ql_get_curr_lchunk(qdev, rx_ring);
> size = min(length, qdev->lbq_buf_size);
>
> @@ -1839,7 +1836,7 @@ static struct sk_buff *ql_build_rx_skb(struct ql_adapter *qdev,
> skb->truesize += size;
> length -= size;
> i++;
> - } while (length > 0);
> + }
Looks like length and i modification should be removed from here. But in
this instance, maybe the original was better anyways.
Agreed with Dan. At least some of those loops can be converted to "count
up" loops for a more familiar appearance.
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)
Powered by blists - more mailing lists