[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <dd01a117-265a-e64b-5871-22f0f752834a@linaro.org>
Date: Fri, 17 Jul 2020 06:20:59 +0200
From: Daniel Lezcano <daniel.lezcano@...aro.org>
To: 周琰杰 (Zhou Yanjie)
<zhouyanjie@...yeetech.com>, linux-kernel@...r.kernel.org
Cc: devicetree@...r.kernel.org, robh+dt@...nel.org, tglx@...utronix.de,
paul@...pouillou.net, dongsheng.qiu@...enic.com,
aric.pzqi@...enic.com, rick.tyliu@...enic.com,
yanfei.li@...enic.com, sernia.zhou@...mail.com,
zhenwenjin@...il.com
Subject: Re: [PATCH v6 2/2] clocksource: Ingenic: Add support for the Ingenic
X1000 OST.
On 10/07/2020 19:02, 周琰杰 (Zhou Yanjie) wrote:
> X1000 and SoCs after X1000 (such as X1500 and X1830) had a separate
> OST, it no longer belongs to TCU. This driver will register both a
> clocksource and a sched_clock to the system.
>
> Tested-by: 周正 (Zhou Zheng) <sernia.zhou@...mail.com>
> Co-developed-by: 漆鹏振 (Qi Pengzhen) <aric.pzqi@...enic.com>
> Signed-off-by: 漆鹏振 (Qi Pengzhen) <aric.pzqi@...enic.com>
> Signed-off-by: 周琰杰 (Zhou Yanjie) <zhouyanjie@...yeetech.com>
> Reviewed-by: Paul Cercueil <paul@...pouillou.net>
> ---
>
> Notes:
> v1->v2:
> Fix compile warnings.
> Reported-by: kernel test robot <lkp@...el.com>
>
> v2->v3:
> No change.
>
> v3->v4:
> 1.Rename "ost" to "sysost"
> 1.Remove unrelated changes.
> 2.Remove ost_clock_parent enum.
> 3.Remove ost->percpu_timer_channel/ost->global_timer_channel.
> 4.Set up independent .recalc_rate/.set_rate for percpu/global timer.
> 5.No longer call functions in variable declarations.
>
> v4->v5:
> Use "of_io_request_and_map()" instead "of_iomap()".
> Suggested-by: Paul Cercueil <paul@...pouillou.net>
>
> v5->v6:
> No change.
>
> drivers/clocksource/Kconfig | 11 +
> drivers/clocksource/Makefile | 1 +
> drivers/clocksource/ingenic-sysost.c | 539 +++++++++++++++++++++++++++++++++++
> 3 files changed, 551 insertions(+)
> create mode 100644 drivers/clocksource/ingenic-sysost.c
>
> diff --git a/drivers/clocksource/Kconfig b/drivers/clocksource/Kconfig
> index 91418381fcd4..1bca8b8fb30f 100644
> --- a/drivers/clocksource/Kconfig
> +++ b/drivers/clocksource/Kconfig
> @@ -696,6 +696,17 @@ config INGENIC_TIMER
> help
> Support for the timer/counter unit of the Ingenic JZ SoCs.
>
> +config INGENIC_SYSOST
> + bool "Clocksource/timer using the SYSOST in Ingenic X SoCs"
We usually use silent options and let the platform's Kconfig enable it.
We show up the option only when COMPILE_TEST is enabled.
Is there a reason to do it differently?
> + default MACH_INGENIC
> + depends on MIPS || COMPILE_TEST
> + depends on COMMON_CLK
> + select MFD_SYSCON
> + select TIMER_OF
> + select IRQ_DOMAIN
> + help
> + Support for the SYSOST of the Ingenic X Series SoCs.
> +
[ ... ]
--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs
Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog
Powered by blists - more mailing lists