[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200717171108.6e9f1b16@endymion>
Date: Fri, 17 Jul 2020 17:11:08 +0200
From: Jean Delvare <jdelvare@...e.de>
To: "Saheed O. Bolarinwa" <refactormyself@...il.com>
Cc: helgaas@...nel.org, bjorn@...gaas.com, skhan@...uxfoundation.org,
linux-pci@...r.kernel.org,
linux-kernel-mentees@...ts.linuxfoundation.org,
linux-kernel@...r.kernel.org, linux-i2c@...r.kernel.org
Subject: Re: [RFC PATCH 15/35] i2c/busses: Tidy Success/Failure checks
On Mon, 13 Jul 2020 14:22:27 +0200, Saheed O. Bolarinwa wrote:
> Signed-off-by: "Saheed O. Bolarinwa" <refactormyself@...il.com>
> ---
> This patch depends on PATCH 15/35
Not possible, as this *is* patch 15/35. Not really worth mentioning
anyway, as it is expected that patches in a given series may depend on
any earlier patch in the same series.
>
> drivers/i2c/busses/i2c-ali15x3.c | 5 ++---
> drivers/i2c/busses/i2c-nforce2.c | 3 +--
> drivers/i2c/busses/i2c-sis5595.c | 15 +++++----------
> 3 files changed, 8 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/i2c/busses/i2c-ali15x3.c b/drivers/i2c/busses/i2c-ali15x3.c
> index 359ee3e0864a..c9e779cc184e 100644
> --- a/drivers/i2c/busses/i2c-ali15x3.c
> +++ b/drivers/i2c/busses/i2c-ali15x3.c
> @@ -167,11 +167,10 @@ static int ali15x3_setup(struct pci_dev *ALI15X3_dev)
> if(force_addr) {
> dev_info(&ALI15X3_dev->dev, "forcing ISA address 0x%04X\n",
> ali15x3_smba);
> - if (0 != pci_write_config_word(ALI15X3_dev,
> - SMBBA,
> + if (pci_write_config_word(ALI15X3_dev, SMBBA,
> ali15x3_smba))
> goto error;
You can't possibly leave the code with such a ugly alignment and run
away. The whole point of tidying patches it to have more readable code
in the end, right?
> - if (0 != pci_read_config_word(ALI15X3_dev,
> + if (pci_read_config_word(ALI15X3_dev,
> SMBBA, &a))
> goto error;
> if ((a & ~(ALI15X3_SMB_IOSIZE - 1)) != ali15x3_smba) {
> diff --git a/drivers/i2c/busses/i2c-nforce2.c b/drivers/i2c/busses/i2c-nforce2.c
> index 385f4f446f36..54d2985b7aaf 100644
> --- a/drivers/i2c/busses/i2c-nforce2.c
> +++ b/drivers/i2c/busses/i2c-nforce2.c
> @@ -327,8 +327,7 @@ static int nforce2_probe_smb(struct pci_dev *dev, int bar, int alt_reg,
> /* Older incarnations of the device used non-standard BARs */
> u16 iobase;
>
> - if (pci_read_config_word(dev, alt_reg, &iobase)
> - != 0) {
> + if (pci_read_config_word(dev, alt_reg, &iobase)) {
> dev_err(&dev->dev, "Error reading PCI config for %s\n",
> name);
> return -EIO;
> diff --git a/drivers/i2c/busses/i2c-sis5595.c b/drivers/i2c/busses/i2c-sis5595.c
> index fbe3ee31eae3..b016f48519d3 100644
> --- a/drivers/i2c/busses/i2c-sis5595.c
> +++ b/drivers/i2c/busses/i2c-sis5595.c
> @@ -175,11 +175,9 @@ static int sis5595_setup(struct pci_dev *SIS5595_dev)
>
> if (force_addr) {
> dev_info(&SIS5595_dev->dev, "forcing ISA address 0x%04X\n", sis5595_base);
> - if (pci_write_config_word(SIS5595_dev, ACPI_BASE, sis5595_base)
> - != 0)
> + if (pci_write_config_word(SIS5595_dev, ACPI_BASE, sis5595_base))
> goto error;
> - if (pci_read_config_word(SIS5595_dev, ACPI_BASE, &a)
> - != 0)
> + if (pci_read_config_word(SIS5595_dev, ACPI_BASE, &a))
> goto error;
> if ((a & ~(SIS5595_EXTENT - 1)) != sis5595_base) {
> /* doesn't work for some chips! */
> @@ -188,16 +186,13 @@ static int sis5595_setup(struct pci_dev *SIS5595_dev)
> }
> }
>
> - if (pci_read_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, &val)
> - != 0)
> + if (pci_read_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, &val))
> goto error;
> if ((val & 0x80) == 0) {
> dev_info(&SIS5595_dev->dev, "enabling ACPI\n");
> - if (pci_write_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, val | 0x80)
> - != 0)
> + if (pci_write_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, val | 0x80))
> goto error;
> - if (pci_read_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, &val)
> - != 0)
> + if (pci_read_config_byte(SIS5595_dev, SIS5595_ENABLE_REG, &val))
> goto error;
> if ((val & 0x80) == 0) {
> /* doesn't work for some chips? */
Overall I'd be happy to have a more consistent style for checking
errors on PCI config registers access, so this seems to be going into
the right direction.
--
Jean Delvare
SUSE L3 Support
Powered by blists - more mailing lists