lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 19 Jul 2020 13:08:35 +0300
From:   Shay Agroskin <shayagr@...zon.com>
To:     Joe Perches <joe@...ches.com>
CC:     Wang Hai <wanghai38@...wei.com>, <netanel@...zon.com>,
        <akiyano@...zon.com>, <gtzalik@...zon.com>, <saeedb@...zon.com>,
        <zorik@...zon.com>, <davem@...emloft.net>, <kuba@...nel.org>,
        <sameehj@...zon.com>, <netdev@...r.kernel.org>,
        <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH -next] net: ena: use NULL instead of zero


Joe Perches <joe@...ches.com> writes:

> On Sat, 2020-07-18 at 19:56 +0800, Wang Hai wrote:
>> Fix sparse build warning:
>> 
>> drivers/net/ethernet/amazon/ena/ena_netdev.c:2193:34: warning:
>>  Using plain integer as NULL pointer
>
> Better to remove the initialization altogether and
> move the declaration into the loop.
>
>> diff --git a/drivers/net/ethernet/amazon/ena/ena_netdev.c 
>> b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> []
>> @@ -2190,7 +2190,7 @@ static void ena_del_napi_in_range(struct 
>> ena_adapter *adapter,
>>  static void ena_init_napi_in_range(struct ena_adapter 
>>  *adapter,
>>  				   int first_index, int count)
>>  {
>> -	struct ena_napi *napi = {0};
>> +	struct ena_napi *napi = NULL;
>>  	int i;
>>  
>>  	for (i = first_index; i < first_index + count; i++) {
>
> ---
>  drivers/net/ethernet/amazon/ena/ena_netdev.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/amazon/ena/ena_netdev.c 
> b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> index 91be3ffa1c5c..470d8f38b824 100644
> --- a/drivers/net/ethernet/amazon/ena/ena_netdev.c
> +++ b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> @@ -2190,11 +2190,10 @@ static void ena_del_napi_in_range(struct 
> ena_adapter *adapter,
>  static void ena_init_napi_in_range(struct ena_adapter *adapter,
>  				   int first_index, int count)
>  {
> -	struct ena_napi *napi = {0};
>  	int i;
>  
>  	for (i = first_index; i < first_index + count; i++) {
> -		napi = &adapter->ena_napi[i];
> +		struct ena_napi *napi = &adapter->ena_napi[i];
>  
>  		netif_napi_add(adapter->netdev,
>  			       &adapter->ena_napi[i].napi,

We prefer the second variant as it improves code readability imo.
Thank you both for the time you invested in it (:

Acked-by: Shay Agroskin <shayagr@...zon.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ