[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200721163151.GA643353@iweiny-DESK2.sc.intel.com>
Date: Tue, 21 Jul 2020 09:31:52 -0700
From: Ira Weiny <ira.weiny@...el.com>
To: Peter Zijlstra <peterz@...radead.org>
Cc: Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Andy Lutomirski <luto@...nel.org>, x86@...nel.org,
Dave Hansen <dave.hansen@...ux.intel.com>,
Dan Williams <dan.j.williams@...el.com>,
Vishal Verma <vishal.l.verma@...el.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Fenghua Yu <fenghua.yu@...el.com>, linux-doc@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-nvdimm@...ts.01.org,
linux-fsdevel@...r.kernel.org, linux-mm@...ck.org,
linux-kselftest@...r.kernel.org
Subject: Re: [PATCH RFC V2 13/17] kmap: Add stray write protection for device
pages
On Mon, Jul 20, 2020 at 11:17:40AM +0200, Peter Zijlstra wrote:
> On Sat, Jul 18, 2020 at 09:13:19PM -0700, Ira Weiny wrote:
> > On Fri, Jul 17, 2020 at 11:21:39AM +0200, Peter Zijlstra wrote:
> > > On Fri, Jul 17, 2020 at 12:20:52AM -0700, ira.weiny@...el.com wrote:
> > > > @@ -31,6 +32,20 @@ static inline void invalidate_kernel_vmap_range(void *vaddr, int size)
> > > >
> > > > #include <asm/kmap_types.h>
> > > >
> > > > +static inline void enable_access(struct page *page)
> > > > +{
> > > > + if (!page_is_access_protected(page))
> > > > + return;
> > > > + dev_access_enable();
> > > > +}
> > > > +
> > > > +static inline void disable_access(struct page *page)
> > > > +{
> > > > + if (!page_is_access_protected(page))
> > > > + return;
> > > > + dev_access_disable();
> > > > +}
> > >
> > > These are some very generic names, do we want them to be a little more
> > > specific?
> >
> > I had them named kmap_* but Dave (I think it was Dave) thought they did not
> > really apply strictly to kmap_*.
> >
> > They are static to this file which I thought may be sufficient to 'uniqify'
> > them?
>
> They're static to a .h, which means they're all over the place ;-)
I've thought about it a bit. I think I agree with both you and Dave.
How about:
dev_page_{en,dis}able_access()
??
I've made that change for now.
Thanks,
Ira
Powered by blists - more mailing lists