lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Wed, 22 Jul 2020 12:38:59 +0200
From:   Matthias Brugger <matthias.bgg@...il.com>
To:     lei liu <leilk.liu@...iatek.com>
Cc:     Mark Brown <broonie@...nel.org>,
        Mark Rutland <mark.rutland@....com>,
        Sascha Hauer <s.hauer@...gutronix.de>,
        devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
        linux-arm-kernel@...ts.infradead.org, linux-spi@...r.kernel.org,
        linux-mediatek@...ts.infradead.org
Subject: Re: [PATCH v2 2/2] spi: mediatek: add spi support for mt8192 IC



On 22/07/2020 10:38, lei liu wrote:
> On Wed, 2020-07-22 at 00:44 +0200, Matthias Brugger wrote:
>>
>> On 21/07/2020 14:24, Leilk Liu wrote:
>>> From: "leilk.liu" <leilk.liu@...iatek.com>
>>>
>>> This patch add spi support for mt8192 IC.
>>>
>>> Signed-off-by: leilk.liu <leilk.liu@...iatek.com>
>>> ---
>>>    drivers/spi/spi-mt65xx.c | 3 +++
>>>    1 file changed, 3 insertions(+)
>>>
>>> diff --git a/drivers/spi/spi-mt65xx.c b/drivers/spi/spi-mt65xx.c
>>> index 6783e12c40c2..3d0d69fe0c69 100644
>>> --- a/drivers/spi/spi-mt65xx.c
>>> +++ b/drivers/spi/spi-mt65xx.c
>>> @@ -170,6 +170,9 @@ static const struct of_device_id mtk_spi_of_match[] = {
>>>    	{ .compatible = "mediatek,mt8183-spi",
>>>    		.data = (void *)&mt8183_compat,
>>>    	},
>>> +	{ .compatible = "mediatek,mt8192-spi",
>>> +		.data = (void *)&mt6765_compat,
>>> +	},
>>
>> That's not needed. We will use the fallback compatible which is
>> "mediatek,mt6765-spi" which will take the correct DT data. If in the future we
>> realize that mt8192 has a difference in the HW we can add the compatible.
>> Otherwise with the binding description we should be fine
>>
> So you mean that only the following binding patch is needed?
> [PATCH v2 1/2] dt-bindings: spi: update bindings for MT8192 SoC
> 

Yes, exactly.

Regards,
Matthias

Powered by blists - more mailing lists