[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200725023633.GC17052@linux.intel.com>
Date: Sat, 25 Jul 2020 05:36:33 +0300
From: Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>
To: Ingo Molnar <mingo@...nel.org>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
Andi Kleen <ak@...ux.intel.com>,
Peter Zijlstra <peterz@...radead.org>,
Masami Hiramatsu <mhiramat@...nel.org>,
Jessica Yu <jeyu@...nel.org>,
"Naveen N. Rao" <naveen.n.rao@...ux.ibm.com>,
Anil S Keshavamurthy <anil.s.keshavamurthy@...el.com>,
"David S. Miller" <davem@...emloft.net>,
Steven Rostedt <rostedt@...dmis.org>,
Ingo Molnar <mingo@...hat.com>
Subject: Re: [PATCH v5 1/6] kprobes: Remove dependency to the module_mutex
On Fri, Jul 24, 2020 at 11:13:19AM +0200, Ingo Molnar wrote:
>
> * Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com> wrote:
>
> > Add lock_modules() and unlock_modules() wrappers for acquiring module_mutex
> > in order to remove the compile time dependency to it.
> >
> > Cc: linux-mm@...ck.org
> > Cc: Andi Kleen <ak@...ux.intel.com>
> > Cc: Peter Zijlstra <peterz@...radead.org>
> > Suggested-by: Masami Hiramatsu <mhiramat@...nel.org>
> > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>
> > ---
> > include/linux/module.h | 18 ++++++++++++++++++
> > kernel/kprobes.c | 4 ++--
> > kernel/trace/trace_kprobe.c | 4 ++--
> > 3 files changed, 22 insertions(+), 4 deletions(-)
> >
> > diff --git a/include/linux/module.h b/include/linux/module.h
> > index 2e6670860d27..8850b9692b8f 100644
> > --- a/include/linux/module.h
> > +++ b/include/linux/module.h
> > @@ -705,6 +705,16 @@ static inline bool is_livepatch_module(struct module *mod)
> > bool is_module_sig_enforced(void);
> > void set_module_sig_enforced(void);
> >
> > +static inline void lock_modules(void)
> > +{
> > + mutex_lock(&module_mutex);
> > +}
> > +
> > +static inline void unlock_modules(void)
> > +{
> > + mutex_unlock(&module_mutex);
> > +}
> > +
> > #else /* !CONFIG_MODULES... */
> >
> > static inline struct module *__module_address(unsigned long addr)
> > @@ -852,6 +862,14 @@ void *dereference_module_function_descriptor(struct module *mod, void *ptr)
> > return ptr;
> > }
> >
> > +static inline void lock_modules(void)
> > +{
> > +}
> > +
> > +static inline void unlock_modules(void)
> > +{
> > +}
>
> Minor namespace nit: when introducing new locking wrappers please
> standardize on the XYZ_lock()/XYZ_unlock() nomenclature, i.e.:
>
> modules_lock()
> ...
> modules_unlock()
>
> Similarly to the mutex_lock/unlock(&module_mutex) API that it is
> wrapping.
>
> Also, JFYI, the overwhelming majority of the modules related APIs use
> module_*(), i.e. singular - not plural, so
> module_lock()/module_unlock() would be the more canonical choice.
> (But both sound fine to me)
Thanks, I renamed them as module_lock() and module_unlock().
> Thanks,
>
> Ingo
/Jarkko
Powered by blists - more mailing lists