[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <159596731796.1360974.3913058992312532558@swboyd.mtv.corp.google.com>
Date: Tue, 28 Jul 2020 13:15:17 -0700
From: Stephen Boyd <swboyd@...omium.org>
To: Andy Shevchenko <andy.shevchenko@...il.com>,
Daniel Campello <campello@...omium.org>
Cc: LKML <devicetree@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>,
Jonathan Cameron <jic23@...nel.org>,
Douglas Anderson <dianders@...omium.org>,
Gwendal Grignou <gwendal@...omium.org>,
Hartmut Knaack <knaack.h@....de>,
Lars-Peter Clausen <lars@...afoo.de>,
Peter Meerwald-Stadler <pmeerw@...erw.net>,
linux-iio <linux-iio@...r.kernel.org>
Subject: Re: [PATCH 03/15] iio: sx9310: Fix irq handling
Quoting Daniel Campello (2020-07-28 13:07:00)
> On Tue, Jul 28, 2020 at 12:08 PM Andy Shevchenko
> <andy.shevchenko@...il.com> wrote:
> >
> > On Tue, Jul 28, 2020 at 6:14 PM Daniel Campello <campello@...omium.org> wrote:
> > >
> > > Fixes enable/disable irq handling at various points. The driver needs to
> > > only enable/disable irqs if there is an actual irq handler installed.
> >
> > > - enable_irq(data->client->irq);
> > > + if (!ret)
> > > + enable_irq(data->client->irq);
> > >
> > > return ret;
> > > }
> >
> > Can it be a usual pattern?
> >
> > if (ret)
> > return ret;
> > ...
> > return 0;
>
> I think this way is more readable. The alternative would have to be
> something like this:
>
> ....
> if (ret)
> goto out;
> mutex_unlock(&data->mutex);
> enable_irq(data->client->irq);
> return 0;
>
> out:
> mutex_unlock(&data->mutex);
> return ret;
>
I think the suggestion is
mutex_unlock(&data->mutex);
if (ret)
return ret;
enable_irq(data->client->irq);
return 0;
Powered by blists - more mailing lists