[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200731024049.16495-1-hsiangkao@aol.com>
Date: Fri, 31 Jul 2020 10:40:49 +0800
From: Gao Xiang <hsiangkao@....com>
To: linux-erofs@...ts.ozlabs.org
Cc: LKML <linux-kernel@...r.kernel.org>,
Gao Xiang <hsiangkao@...hat.com>,
Maksym Planeta <mplaneta@...inf.tu-dresden.de>
Subject: [PATCH] erofs: remove WQ_CPU_INTENSIVE flag from unbound wq's
From: Gao Xiang <hsiangkao@...hat.com>
The documentation [1] says that WQ_CPU_INTENSIVE is "meaningless" for
unbound wq. I remove this flag from places where unbound queue is
allocated. This is supposed to improve code readability.
[1] https://www.kernel.org/doc/html/latest/core-api/workqueue.html#flags
Signed-off-by: Maksym Planeta <mplaneta@...inf.tu-dresden.de>
[Gao Xiang: since the original treewide patch [2] hasn't been merged
yet, handling the EROFS part only for the next cycle. ]
[2] https://lore.kernel.org/r/20200213141823.2174236-1-mplaneta@os.inf.tu-dresden.de
Signed-off-by: Gao Xiang <hsiangkao@...hat.com>
---
fs/erofs/zdata.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/fs/erofs/zdata.c b/fs/erofs/zdata.c
index 80bf09c4de09..9ac2723c11bf 100644
--- a/fs/erofs/zdata.c
+++ b/fs/erofs/zdata.c
@@ -43,13 +43,13 @@ void z_erofs_exit_zip_subsystem(void)
static inline int z_erofs_init_workqueue(void)
{
const unsigned int onlinecpus = num_possible_cpus();
- const unsigned int flags = WQ_UNBOUND | WQ_HIGHPRI | WQ_CPU_INTENSIVE;
/*
* no need to spawn too many threads, limiting threads could minimum
* scheduling overhead, perhaps per-CPU threads should be better?
*/
- z_erofs_workqueue = alloc_workqueue("erofs_unzipd", flags,
+ z_erofs_workqueue = alloc_workqueue("erofs_unzipd",
+ WQ_UNBOUND | WQ_HIGHPRI,
onlinecpus + onlinecpus / 4);
return z_erofs_workqueue ? 0 : -ENOMEM;
}
--
2.24.0
Powered by blists - more mailing lists