[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9ff6babc-d525-e0b1-ca6c-9c8b24e5a07f@oracle.com>
Date: Mon, 10 Aug 2020 14:46:21 -0700
From: Mike Kravetz <mike.kravetz@...cle.com>
To: Wei Yang <richard.weiyang@...ux.alibaba.com>,
akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 04/10] mm/hugetlb: count file_region to be added when
regions_needed != NULL
On 8/7/20 2:12 AM, Wei Yang wrote:
> There are only two cases of function add_reservation_in_range()
>
> * count file_region and return the number in regions_needed
> * do the real list operation without counting
>
> This means it is not necessary to have two parameters to classify these
> two cases.
>
> Just use regions_needed to separate them.
>
> Signed-off-by: Wei Yang <richard.weiyang@...ux.alibaba.com>
Thanks!
I really like removal of the 'count_only' parameter. However, within the
routine 'count_only' made the code just a little easier to understand. I
might have:
- Removed the function parameter.
- Added local variable
bool count_only = regions_needed != NULL;
- Left remaining code as it.
I'm OK with the proposed change. Any change to readability is VERY minimal.
Reviewed-by: Mike Kravetz <mike.kravetz@...cle.com>
--
Mike Kravetz
Powered by blists - more mailing lists