[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200813213409.24222-1-digetx@gmail.com>
Date: Fri, 14 Aug 2020 00:33:59 +0300
From: Dmitry Osipenko <digetx@...il.com>
To: Sebastian Reichel <sre@...nel.org>,
Rob Herring <robh+dt@...nel.org>,
Andy Gross <agross@...nel.org>,
Bjorn Andersson <bjorn.andersson@...aro.org>,
David Heidelberg <david@...t.cz>,
Thierry Reding <thierry.reding@...il.com>,
Jonathan Hunter <jonathanh@...dia.com>,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
"Bruce E . Robertson" <bruce.e.robertson@...el.com>
Cc: linux-pm@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-arm-msm@...r.kernel.org,
Jonghwa Lee <jonghwa3.lee@...sung.com>,
John Stultz <john.stultz@...aro.org>,
Vinay Simha BN <simhavcs@...il.com>,
linux-tegra@...r.kernel.org
Subject: [PATCH v3 00/10] Summit SMB3xx driver & device-tree
We gathered existing patches, fixed and improved what we could and
final result is an working charging driver with device-tree support
for Nexus 7.
At this moment charging works with:
- Nexus 7 2012 (grouper and tilapia)
- Nexus 7 2013 (flo and deb)
- ... and there are more devices equipped with these chargers.
Changelog:
v3: - The uint32 type now isn't specified for standard units in the SMB
DT binding because standard units already have a type.
Thanks to Rob Herring for the suggestion!
- The battery binding changes are rebased on top of the new battery.yaml
- The new battery temperature DT properties now have shorter names
and use <min max> format. Thanks to Rob Herring for the suggestion!
- Added new patch that adds SMB charger node to the new Nexus 7 2012
device-tree which has been merged into v5.9 kernel.
v2: - Addressed v1 review comments from Rob Herring and Sebastian Reichel
by moving out common battery properties from the charger node into the
battery-cell node.
- power_supply_register() of the SMB driver converted to resource-managed
API variant.
- Improved DT property names of the SMB binding by making them to follow
the generic power-supply naming scheme (-microvolts at the end, etc).
David Heidelberg (7):
dt-bindings: power: supply: Add device-tree binding for Summit SMB3xx
power: supply: smb347-charger: Use resource-managed API
power: supply: smb347-charger: Implement device-tree support
power: supply: smb347-charger: Support SMB345 and SMB358
power: supply: smb347-charger: Remove virtual smb347-battery
ARM: dts: qcom: apq8064-nexus7: Add SMB345 battery charger
ARM: tegra: nexus7: Add SMB347 battery charger
Dmitry Osipenko (3):
dt-bindings: battery: Add temperature properties
power: supply: Support battery temperature device-tree properties
power: supply: smb347-charger: Replace mutex with IRQ disable/enable
.../bindings/power/supply/battery.yaml | 24 +
.../power/supply/summit,smb347-charger.yaml | 152 +++++
.../boot/dts/qcom-apq8064-asus-nexus7-flo.dts | 24 +
.../tegra30-asus-nexus7-grouper-common.dtsi | 24 +-
drivers/power/supply/Kconfig | 6 +-
drivers/power/supply/power_supply_core.c | 19 +
drivers/power/supply/smb347-charger.c | 565 +++++++++---------
.../dt-bindings/power/summit,smb347-charger.h | 19 +
include/linux/power_supply.h | 6 +
9 files changed, 568 insertions(+), 271 deletions(-)
create mode 100644 Documentation/devicetree/bindings/power/supply/summit,smb347-charger.yaml
create mode 100644 include/dt-bindings/power/summit,smb347-charger.h
--
2.27.0
Powered by blists - more mailing lists