[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <AM0PR04MB47726683A69EE5ED162A1D328A400@AM0PR04MB4772.eurprd04.prod.outlook.com>
Date: Fri, 14 Aug 2020 03:28:58 +0000
From: Jiafei Pan <jiafei.pan@....com>
To: Peter Zijlstra <peterz@...radead.org>
CC: "mingo@...nel.org" <mingo@...nel.org>,
"tglx@...utronix.de" <tglx@...utronix.de>,
"rostedt@...dmis.org" <rostedt@...dmis.org>,
"romain.perier@...il.com" <romain.perier@...il.com>,
"will@...nel.org" <will@...nel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-rt-users@...r.kernel.org" <linux-rt-users@...r.kernel.org>,
Leo Li <leoyang.li@....com>,
Vladimir Oltean <vladimir.oltean@....com>,
Jiafei Pan <jiafei.pan@....com>
Subject: RE: [EXT] Re: [PATCH] softirq: add irq off checking for
__raise_softirq_irqoff
> From: Peter Zijlstra <peterz@...radead.org>
> Sent: Thursday, August 13, 2020 1:58 PM
>
> On Thu, Aug 06, 2020 at 12:07:29PM +0800, Jiafei Pan wrote:
> > __raise_softirq_irqoff will update per-CPU mask of pending softirqs,
> > it need to be called in irq disabled context in order to keep it
> > atomic operation, otherwise it will be interrupted by hardware
> > interrupt, and per-CPU softirqs pending mask will be corrupted, the
> > result is there will be unexpected issue, for example hrtimer soft irq
> > will be losed and soft hrtimer will never be expire and handled.
> >
> > Adding irqs disabled checking here to provide warning in irqs enabled
> > context.
> >
> > Signed-off-by: Jiafei Pan <Jiafei.Pan@....com>
> > ---
> > kernel/softirq.c | 5 +++++
> > 1 file changed, 5 insertions(+)
> >
> > diff --git a/kernel/softirq.c b/kernel/softirq.c index
> > bf88d7f62433..11f61e54a3ae 100644
> > --- a/kernel/softirq.c
> > +++ b/kernel/softirq.c
> > @@ -481,6 +481,11 @@ void raise_softirq(unsigned int nr)
> >
> > void __raise_softirq_irqoff(unsigned int nr) {
> > + /* This function can only be called in irq disabled context,
> > + * otherwise or_softirq_pending will be interrupted by hardware
> > + * interrupt, so that there will be unexpected issue.
> > + */
>
> Comment style is wrong, also I'm not sure the comment is really helpfull.
[Jiafei Pan] Thanks for your comments, yes, function name already indicate the function
Should be called in irq off context, will remove the comment in next version.
>
> > + WARN_ON_ONCE(!irqs_disabled());
>
> lockdep_assert_irqs_disabled();
>
> > trace_softirq_raise(nr);
> > or_softirq_pending(1UL << nr);
> > }
Powered by blists - more mailing lists