lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200817161615.35dac072@jacob-builder>
Date:   Mon, 17 Aug 2020 16:16:15 -0700
From:   Jacob Pan <jacob.jun.pan@...ux.intel.com>
To:     Auger Eric <eric.auger@...hat.com>
Cc:     iommu@...ts.linux-foundation.org,
        LKML <linux-kernel@...r.kernel.org>,
        Joerg Roedel <joro@...tes.org>,
        Alex Williamson <alex.williamson@...hat.com>,
        Lu Baolu <baolu.lu@...ux.intel.com>,
        David Woodhouse <dwmw2@...radead.org>,
        Yi Liu <yi.l.liu@...el.com>,
        "Tian, Kevin" <kevin.tian@...el.com>,
        Raj Ashok <ashok.raj@...el.com>,
        Christoph Hellwig <hch@...radead.org>,
        Jean-Philippe Brucker <jean-philippe@...aro.com>,
        Jonathan Corbet <corbet@....net>, jacob.jun.pan@...ux.intel.com
Subject: Re: [PATCH v7 5/7] iommu/uapi: Rename uapi functions

On Thu, 13 Aug 2020 10:58:53 +0200
Auger Eric <eric.auger@...hat.com> wrote:

> Hi Jacob,
> 
> On 7/30/20 2:21 AM, Jacob Pan wrote:
> > User APIs such as iommu_sva_unbind_gpasid() may also be used by the
> > kernel. Since we introduced user pointer to the UAPI functions,  
> Practically this is done in the next patch. What about something like:
> 
> We plan to have two flavors of the same API functions, one called
> through ioctls, carrying a user pointer and one called directly with
> valid IOMMU UAPI structs. To differentiate both, let's rename existing
> functions with an iommu_uapi_ prefix.
> 
will do. Thanks!

> Besides
> Reviewed-by: Eric Auger <eric.auger@...hat.com>
> 
> 
> Thanks
> 
> Eric
> > in-kernel callers cannot share the same APIs. In-kernel callers are
> > also trusted, there is no need to validate the data.
> > 
> > This patch renames all UAPI functions with iommu_uapi_ prefix such
> > that is clear to the intended callers.
> > 
> > Suggested-by: Alex Williamson <alex.williamson@...hat.com>
> > Signed-off-by: Jacob Pan <jacob.jun.pan@...ux.intel.com>
> > ---
> >  drivers/iommu/iommu.c | 18 +++++++++---------
> >  include/linux/iommu.h | 31 ++++++++++++++++---------------
> >  2 files changed, 25 insertions(+), 24 deletions(-)
> > 
> > diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
> > index b6858adc4f17..3a913ce94a3d 100644
> > --- a/drivers/iommu/iommu.c
> > +++ b/drivers/iommu/iommu.c
> > @@ -1950,35 +1950,35 @@ int iommu_attach_device(struct iommu_domain
> > *domain, struct device *dev) }
> >  EXPORT_SYMBOL_GPL(iommu_attach_device);
> >  
> > -int iommu_cache_invalidate(struct iommu_domain *domain, struct
> > device *dev,
> > -			   struct iommu_cache_invalidate_info
> > *inv_info) +int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain, struct device *dev,
> > +				struct iommu_cache_invalidate_info
> > *inv_info) {
> >  	if (unlikely(!domain->ops->cache_invalidate))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->cache_invalidate(domain, dev,
> > inv_info); }
> > -EXPORT_SYMBOL_GPL(iommu_cache_invalidate);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_cache_invalidate);
> >  
> > -int iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -			   struct device *dev, struct
> > iommu_gpasid_bind_data *data) +int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +			       struct device *dev, struct
> > iommu_gpasid_bind_data *data) {
> >  	if (unlikely(!domain->ops->sva_bind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_bind_gpasid(domain, dev, data);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_bind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_bind_gpasid);
> >  
> > -int iommu_sva_unbind_gpasid(struct iommu_domain *domain, struct
> > device *dev,
> > -			     ioasid_t pasid)
> > +int iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > struct device *dev,
> > +				 ioasid_t pasid)
> >  {
> >  	if (unlikely(!domain->ops->sva_unbind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_unbind_gpasid(dev, pasid);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_unbind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_unbind_gpasid);
> >  
> >  static void __iommu_detach_device(struct iommu_domain *domain,
> >  				  struct device *dev)
> > diff --git a/include/linux/iommu.h b/include/linux/iommu.h
> > index 5f0b7859d2eb..2dcc1a33f6dc 100644
> > --- a/include/linux/iommu.h
> > +++ b/include/linux/iommu.h
> > @@ -430,13 +430,13 @@ extern int iommu_attach_device(struct
> > iommu_domain *domain, struct device *dev);
> >  extern void iommu_detach_device(struct iommu_domain *domain,
> >  				struct device *dev);
> > -extern int iommu_cache_invalidate(struct iommu_domain *domain,
> > -				  struct device *dev,
> > -				  struct
> > iommu_cache_invalidate_info *inv_info); -extern int
> > iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -		struct device *dev, struct iommu_gpasid_bind_data
> > *data); -extern int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, ioasid_t
> > pasid); +extern int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain,
> > +				       struct device *dev,
> > +				       struct
> > iommu_cache_invalidate_info *inv_info); +extern int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +				      struct device *dev, struct
> > iommu_gpasid_bind_data *data); +extern int
> > iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > +					struct device *dev,
> > ioasid_t pasid); extern struct iommu_domain
> > *iommu_get_domain_for_dev(struct device *dev); extern struct
> > iommu_domain *iommu_get_dma_domain(struct device *dev); extern int
> > iommu_map(struct iommu_domain *domain, unsigned long iova, @@
> > -1054,21 +1054,22 @@ static inline int iommu_sva_get_pasid(struct
> > iommu_sva *handle) return IOMMU_PASID_INVALID; }
> >  
> > -static inline int
> > -iommu_cache_invalidate(struct iommu_domain *domain,
> > -		       struct device *dev,
> > -		       struct iommu_cache_invalidate_info
> > *inv_info) +static inline int iommu_uapi_cache_invalidate(struct
> > iommu_domain *domain,
> > +					      struct device *dev,
> > +					      struct
> > iommu_cache_invalidate_info *inv_info) {
> >  	return -ENODEV;
> >  }
> > -static inline int iommu_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, struct
> > iommu_gpasid_bind_data *data) +
> > +static inline int iommu_uapi_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > +					     struct device *dev,
> > +					     struct
> > iommu_gpasid_bind_data *data) {
> >  	return -ENODEV;
> >  }
> >  
> > -static inline int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -					   struct device *dev, int
> > pasid) +static inline int iommu_uapi_sva_unbind_gpasid(struct
> > iommu_domain *domain,
> > +					       struct device *dev,
> > int pasid) {
> >  	return -ENODEV;
> >  }
> >   
> 

[Jacob Pan]

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ