lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 17 Aug 2020 18:17:35 -0700
From:   Linus Torvalds <>
To:     "Eric W. Biederman" <>
Cc:     Linux Kernel Mailing List <>,
        "<>" <>,, bpf <>,
        Alexander Viro <>,
        Christian Brauner <>,
        Oleg Nesterov <>,
        Cyrill Gorcunov <>,
        Jann Horn <>, Kees Cook <>,
        Daniel P. Berrangé <>,
        Jeff Layton <>,
        Miklos Szeredi <>,
        Matthew Wilcox <>,
        "J. Bruce Fields" <>,
        Matthew Wilcox <>,
        Trond Myklebust <>,
        Chris Wright <>,
        Alexei Starovoitov <>,
        Daniel Borkmann <>,
        Martin KaFai Lau <>,
        Song Liu <>, Yonghong Song <>,
        Andrii Nakryiko <>,
        John Fastabend <>,
        KP Singh <>
Subject: Re: [PATCH 09/17] file: Implement fnext_task

On Mon, Aug 17, 2020 at 6:06 PM Eric W. Biederman <> wrote:
> I struggle with the fcheck name as I have not seen or at least not
> registed on the the user that just checks to see if the result is NULL.
> So the name fcheck never made a bit of sense to me.

Yeah, that name is not great. I just don't want to make things even worse.

> I will see if I can come up with some good descriptive comments around
> these functions.  Along with describing what these things are doing I am
> thinking maybe I should put "_rcu" in their names and have a debug check
> that verifies "_rcu" is held.

Yeah, something along the lines of "rcu_lookup_fd_task(tsk,fd)" would
be a *lot* more descriptive than fcheck_task().

And I think "fnext_task()" could be "rcu_lookup_next_fd_task(tsk,fd)".

Yes, those are much longer names, but it's not like you end up typing
them all that often, and I think being descriptive would be worth it.

And "fcheck()" and "fcheck_files()" would be good to rename too along
the same lines.

Something like "rcu_lookup_fd()" and "rcu_lookup_fd_files()" respectively?

I'm obviously trying to go for a "rcu_lookup_fd*()" kind of pattern,
and I'm not married to _that_ particular pattern but I think it would
be better than what we have now.


Powered by blists - more mailing lists