lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 19 Aug 2020 13:12:10 -0700
From:   Andrew Morton <>
To:     Wei Yang <>
Subject: Re: [PATCH 1/2] mm/mmap: rename __vma_unlink_common() to

On Mon, 10 Aug 2020 07:20:56 +0800 Wei Yang <> wrote:

> __vma_unlink_common() and __vma_unlink() are counterparts. Since there is

I assume you meant "__vma_link()" here?

> not function named __vma_unlink(), let's rename it to __vma_unlink() to
> make the code more self-explain and easy for audience to understand.
> Otherwise we may expect there are several variants of vma_unlink and
> __vma_unlink_common() is used by them.

Powered by blists - more mailing lists