[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200821081449.GI5493@kadam>
Date: Fri, 21 Aug 2020 11:14:49 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: George Acosta <acostag.ubuntu@...il.com>
Cc: Matt Porter <mporter@...nel.crashing.org>,
Alexandre Bounine <alex.bou9@...il.com>,
Andrew Morton <akpm@...ux-foundation.org>,
John Hubbard <jhubbard@...dia.com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Madhuparna Bhowmik <madhuparnabhowmik10@...il.com>,
Kees Cook <keescook@...omium.org>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] rapidio: fix get device imbalance on error
On Thu, Aug 20, 2020 at 10:44:57PM -0500, George Acosta wrote:
> Fix the imbalance in mport_cdev_open.
> Call put_device in error path to balance the
> refcount that increased by the get_device.
>
> Fixes: e8de370188d0 ("rapidio: add mport char device driver")
> Signed-off-by: George Acosta <acostag.ubuntu@...il.com>
> ---
> drivers/rapidio/devices/rio_mport_cdev.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/rapidio/devices/rio_mport_cdev.c b/drivers/rapidio/devices/rio_mport_cdev.c
> index c07ceec3c6d4..3b68e00eb40f 100644
> --- a/drivers/rapidio/devices/rio_mport_cdev.c
> +++ b/drivers/rapidio/devices/rio_mport_cdev.c
> @@ -1908,6 +1908,7 @@ static int mport_cdev_open(struct inode *inode, struct file *filp)
> sizeof(struct rio_event) * MPORT_EVENT_DEPTH,
> GFP_KERNEL);
> if (ret < 0) {
> + put_device(&chdev->dev);
> dev_err(&chdev->dev, DRV_NAME ": kfifo_alloc failed\n");
> ret = -ENOMEM;
> goto err_fifo;
> --
If we ever hit this error path then the:
list_add_tail(&priv->list, &chdev->file_list);
needs to be removed from the list as well or it lead to a use after
free. Probably just move the list_add_tail() after the kfifo_alloc()
has succeeded. We need to remove it from the list in mport_cdev_release()
as well...
The error handling in this function is kind of rubbish.
1) Get rid of the out label and return directly (more readable).
1b) Use "return 0;" instead of "retur ret;" for the success path.
2) Name the labels after what they do not where they "come from". In
other words do.
err_priv:
kfree(priv);
3) Create a label to call put_device:
err_device:
put_device(&chdev->dev);
Change all the error paths to use the goto instead of calling
put_device() before the goto.
regards,
dan carpenter
Powered by blists - more mailing lists