[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200824121840.4cd7eb3dce03e8e1473221b3@linux-foundation.org>
Date: Mon, 24 Aug 2020 12:18:40 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Miaohe Lin <linmiaohe@...wei.com>
Cc: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] mm/mempool: Add 'else' to split mutually exclusive case
On Mon, 24 Aug 2020 07:53:54 -0400 Miaohe Lin <linmiaohe@...wei.com> wrote:
> Add else to split mutually exclusive case and avoid some unnecessary check.
>
> --- a/mm/mempool.c
> +++ b/mm/mempool.c
> @@ -60,9 +60,8 @@ static void check_element(mempool_t *pool, void *element)
> /* Mempools backed by slab allocator */
> if (pool->free == mempool_free_slab || pool->free == mempool_kfree)
> __check_element(pool, element, ksize(element));
> -
> /* Mempools backed by page allocator */
> - if (pool->free == mempool_free_pages) {
> + else if (pool->free == mempool_free_pages) {
> int order = (int)(long)pool->pool_data;
> void *addr = kmap_atomic((struct page *)element);
>
It doesn't seem to change code generation (compiler is smart), but I
think it helps readability.
Powered by blists - more mailing lists