[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200827094415.GA16058@lst.de>
Date: Thu, 27 Aug 2020 11:44:15 +0200
From: Christoph Hellwig <hch@....de>
To: Baolin Wang <baolin.wang@...ux.alibaba.com>
Cc: axboe@...nel.dk, ming.lei@...hat.com, hch@....de,
baolin.wang7@...il.com, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 2/3] block: Add a new helper to attempt to merge a
bio
On Tue, Aug 18, 2020 at 01:45:29PM +0800, Baolin Wang wrote:
> Meanwhile move the blk_mq_bio_list_merge() into blk-merge.c and
> rename it as a generic name.
That should probably a separate patch.
> + if (blk_attempt_bio_merge(q, rq, bio, nr_segs, false) == BIO_MERGE_OK)
> + return true;
This adds an overly long line.
> - if (merged)
> + switch (blk_attempt_bio_merge(q, rq, bio, nr_segs, true)) {
> + default:
> + case BIO_MERGE_NONE:
> + continue;
> + case BIO_MERGE_OK:
> return true;
> + case BIO_MERGE_FAILED:
> + return false;
> + }
I don't think we need a default statement here as we handle all
possible values of the enum.
Powered by blists - more mailing lists