[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200905091448.48165-1-linmiaohe@huawei.com>
Date: Sat, 5 Sep 2020 05:14:48 -0400
From: Miaohe Lin <linmiaohe@...wei.com>
To: <davem@...emloft.net>, <steffen.klassert@...unet.com>,
<willemb@...gle.com>, <mstarovoitov@...vell.com>,
<kuba@...nel.org>, <mchehab+huawei@...nel.org>,
<antoine.tenart@...tlin.com>, <edumazet@...gle.com>,
<Jason@...c4.com>
CC: <netdev@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linmiaohe@...wei.com>
Subject: [PATCH] net: Fix some comments
Since commit 8d7017fd621d ("blackhole_netdev: use blackhole_netdev to
invalidate dst entries"), we use blackhole_netdev to invalidate dst entries
instead of loopback device anymore. Also fix broken NETIF_F_HW_CSUM spell.
Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
---
include/linux/netdev_features.h | 2 +-
net/core/dst.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/netdev_features.h b/include/linux/netdev_features.h
index 2cc3cf80b49a..0b17c4322b09 100644
--- a/include/linux/netdev_features.h
+++ b/include/linux/netdev_features.h
@@ -193,7 +193,7 @@ static inline int find_next_netdev_feature(u64 feature, unsigned long start)
#define NETIF_F_GSO_MASK (__NETIF_F_BIT(NETIF_F_GSO_LAST + 1) - \
__NETIF_F_BIT(NETIF_F_GSO_SHIFT))
-/* List of IP checksum features. Note that NETIF_F_ HW_CSUM should not be
+/* List of IP checksum features. Note that NETIF_F_HW_CSUM should not be
* set in features when NETIF_F_IP_CSUM or NETIF_F_IPV6_CSUM are set--
* this would be contradictory
*/
diff --git a/net/core/dst.c b/net/core/dst.c
index d6b6ced0d451..0c01bd8d9d81 100644
--- a/net/core/dst.c
+++ b/net/core/dst.c
@@ -144,7 +144,7 @@ static void dst_destroy_rcu(struct rcu_head *head)
/* Operations to mark dst as DEAD and clean up the net device referenced
* by dst:
- * 1. put the dst under loopback interface and discard all tx/rx packets
+ * 1. put the dst under blackhole interface and discard all tx/rx packets
* on this route.
* 2. release the net_device
* This function should be called when removing routes from the fib tree
--
2.19.1
Powered by blists - more mailing lists