[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200910234707.5504-1-willy@infradead.org>
Date: Fri, 11 Sep 2020 00:46:58 +0100
From: "Matthew Wilcox (Oracle)" <willy@...radead.org>
To: linux-xfs@...r.kernel.org, linux-fsdevel@...r.kernel.org
Cc: "Matthew Wilcox (Oracle)" <willy@...radead.org>,
"Darrick J . Wong" <darrick.wong@...cle.com>,
Christoph Hellwig <hch@...radead.org>,
linux-nvdimm@...ts.01.org, linux-kernel@...r.kernel.org,
Dave Kleikamp <shaggy@...nel.org>,
jfs-discussion@...ts.sourceforge.net
Subject: [PATCH v2 0/9] THP iomap patches for 5.10
These patches are carefully plucked from the THP series. I would like
them to hit 5.10 to make the THP patchset merge easier. Some of these
are just generic improvements that make sense on their own terms, but
the overall intent is to support THPs in iomap.
v2:
- Move the call to flush_dcache_page (Christoph)
- Clarify comments (Darrick)
- Rename read_count to read_bytes_pending (Christoph)
- Rename write_count to write_bytes_pending (Christoph)
- Restructure iomap_readpage_actor() (Christoph)
- Change return type of the zeroing functions from loff_t to s64
Matthew Wilcox (Oracle) (9):
iomap: Fix misplaced page flushing
fs: Introduce i_blocks_per_page
iomap: Use kzalloc to allocate iomap_page
iomap: Use bitmap ops to set uptodate bits
iomap: Support arbitrarily many blocks per page
iomap: Convert read_count to read_bytes_pending
iomap: Convert write_count to write_bytes_pending
iomap: Convert iomap_write_end types
iomap: Change calling convention for zeroing
fs/dax.c | 13 ++-
fs/iomap/buffered-io.c | 173 +++++++++++++++++-----------------------
fs/jfs/jfs_metapage.c | 2 +-
fs/xfs/xfs_aops.c | 2 +-
include/linux/dax.h | 3 +-
include/linux/pagemap.h | 16 ++++
6 files changed, 96 insertions(+), 113 deletions(-)
--
2.28.0
Powered by blists - more mailing lists