lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 11 Sep 2020 18:10:37 +0300
From:   Dmitry Osipenko <digetx@...il.com>
To:     Jiada Wang <jiada_wang@...tor.com>, nick@...anahar.org,
        dmitry.torokhov@...il.com
Cc:     linux-input@...r.kernel.org, linux-kernel@...r.kernel.org,
        Andrew_Gabbasov@...tor.com, erosca@...adit-jv.com
Subject: Re: [PATCH v3 1/1] Input: atmel_mxt_ts - implement I2C retries

11.09.2020 18:05, Dmitry Osipenko пишет:
> 11.09.2020 17:50, Dmitry Osipenko пишет:
> ...
>>> @@ -626,6 +627,7 @@ static int __mxt_read_reg(struct i2c_client *client,
>>>  	struct i2c_msg xfer[2];
>>>  	u8 buf[2];
>>>  	int ret;
>>> +	bool retry = false;
> 
> Andy suggested to write this hunk like this:
> 
> 	struct i2c_msg xfer[2];
> 	bool retry = false;
> 	u8 buf[2];
> 	int ret;
> 
> This is not a mandatory request at all, but it will make this particular
> piece of code to look a bit nicer.
> 
> There is also an opportunity to improve formatting of all variables by
> sorting them by-length across the whole driver, this will improve
> readability of the code. But of course it should be a separate patch.
> Please note that I'm *not* saying that you should create this separate
> patch!
> 

I'd also recommend to rename the "retry" variable to "retried", which
will be a more logical name (more proper English).

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ