[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <38299e7c135de26dc7cf3fbe25d6a74e4632bbd9.camel@perches.com>
Date: Sat, 12 Sep 2020 11:43:49 -0700
From: Joe Perches <joe@...ches.com>
To: Michael Straube <straube.linux@...il.com>,
gregkh@...uxfoundation.org
Cc: hdegoede@...hat.com, Larry.Finger@...inger.net,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/5] staging: rtl8723bs: refactor cckrates{only}_included
On Sat, 2020-09-12 at 11:22 -0700, Joe Perches wrote:
> On Sat, 2020-09-12 at 10:45 +0200, Michael Straube wrote:
> > Refactor cckrates_included() and cckratesonly_included() to simplify
> > the code and improve readability.
[]
> diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.c b/drivers/staging/rtl8723bs/core/rtw_wlan_util.c
[]
> bool cckratesonly_included(unsigned char *rate, int ratelen)
> {
[]
> if (i <= 0)
if (ratelen <= 0) of course...
> return false;
>
> for (i = 0; i < ratelen; i++) {
> if (!is_cckrate(rate[i])
> return false;
> }
>
> return true;
> }
>
>
Powered by blists - more mailing lists