[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <170592eceb26da041f276cf4ca33aaf2@codeaurora.org>
Date: Mon, 14 Sep 2020 11:43:12 -0700
From: nguyenb@...eaurora.org
To: Avri Altman <Avri.Altman@....com>
Cc: cang@...eaurora.org, asutoshd@...eaurora.org,
martin.petersen@...cle.com, linux-scsi@...r.kernel.org,
linux-arm-msm@...r.kernel.org,
Alim Akhtar <alim.akhtar@...sung.com>,
"James E.J. Bottomley" <jejb@...ux.ibm.com>,
YueHaibing <yuehaibing@...wei.com>,
Bean Huo <beanhuo@...ron.com>,
open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v1 2/2] scsi: ufs: Support reading UFS's Vcc voltage from
device tree
On 2020-09-13 02:37, Avri Altman wrote:
>>
>> The UFS specifications supports a range of Vcc operating voltage
>> from 2.4-3.6V depending on the device and manufacturers.
>> Allows selecting the UFS Vcc voltage level by setting the
>> UFS's entry vcc-voltage-level in the device tree. If UFS's
>> vcc-voltage-level setting is not found in the device tree,
>> use default values provided by the driver.
>>
>> Signed-off-by: Can Guo <cang@...eaurora.org>
>> Signed-off-by: Asutosh Das <asutoshd@...eaurora.org>
>> Signed-off-by: Bao D. Nguyen <nguyenb@...eaurora.org>
>> ---
>> drivers/scsi/ufs/ufshcd-pltfrm.c | 15 ++++++++++++---
>> 1 file changed, 12 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/scsi/ufs/ufshcd-pltfrm.c
>> b/drivers/scsi/ufs/ufshcd-pltfrm.c
>> index 3db0af6..48f429c 100644
>> --- a/drivers/scsi/ufs/ufshcd-pltfrm.c
>> +++ b/drivers/scsi/ufs/ufshcd-pltfrm.c
>> @@ -104,10 +104,11 @@ static int ufshcd_parse_clock_info(struct
>> ufs_hba
>> *hba)
>> static int ufshcd_populate_vreg(struct device *dev, const char *name,
>> struct ufs_vreg **out_vreg)
>> {
>> - int ret = 0;
>> + int len, ret = 0;
>> char prop_name[MAX_PROP_SIZE];
>> struct ufs_vreg *vreg = NULL;
>> struct device_node *np = dev->of_node;
>> + const __be32 *prop;
>>
>> if (!np) {
>> dev_err(dev, "%s: non DT initialization\n", __func__);
>> @@ -138,8 +139,16 @@ static int ufshcd_populate_vreg(struct device
>> *dev,
>> const char *name,
>> vreg->min_uV = UFS_VREG_VCC_1P8_MIN_UV;
>> vreg->max_uV = UFS_VREG_VCC_1P8_MAX_UV;
>> } else {
>> - vreg->min_uV = UFS_VREG_VCC_MIN_UV;
>> - vreg->max_uV = UFS_VREG_VCC_MAX_UV;
>> + prop = of_get_property(np,
>> "vcc-voltage-level", &len);
>> + if (!prop || (len != (2 * sizeof(__be32)))) {
>> + dev_warn(dev, "%s vcc-voltage-level
>> property.\n",
>> + prop ? "invalid format" :
>> "no");
>> + vreg->min_uV = UFS_VREG_VCC_MIN_UV;
>> + vreg->max_uV = UFS_VREG_VCC_MAX_UV;
>> + } else {
>> + vreg->min_uV = be32_to_cpup(&prop[0]);
>> + vreg->max_uV = be32_to_cpup(&prop[1]);
>> + }
>> }
>> } else if (!strcmp(name, "vccq")) {
>> vreg->min_uV = UFS_VREG_VCCQ_MIN_UV;
>> --
> Maybe instead call ufshcd_populate_vreg with the new name,
> To not break the function flow, and just add another else if ?
Could you please clarify your comments? Are you suggesting to create a
new function?
Thank you.
Powered by blists - more mailing lists