[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200914084904.GA16999@dhcp22.suse.cz>
Date: Mon, 14 Sep 2020 10:49:04 +0200
From: Michal Hocko <mhocko@...e.com>
To: Laurent Dufour <ldufour@...ux.ibm.com>
Cc: akpm@...ux-foundation.org, David Hildenbrand <david@...hat.com>,
Oscar Salvador <osalvador@...e.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-mm@...ck.org, "Rafael J . Wysocki" <rafael@...nel.org>,
nathanl@...ux.ibm.com, cheloha@...ux.ibm.com,
Tony Luck <tony.luck@...el.com>,
Fenghua Yu <fenghua.yu@...el.com>, linux-ia64@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] mm: replace memmap_context by memplug_context
On Fri 11-09-20 15:48:29, Laurent Dufour wrote:
> The memmap_context is used to detect whether a memory operation is due to a
> hot-add operation or happening at boot time.
>
> Makes it general to the hotplug operation, renaming it at memplug_context
> and move its define in the corresponding header.
>
> There is no functional change introduced by this patch
I do not want to nit picking on naming but we want to look at this from
the initialization POV rather than hotplug. So....
>
> Suggested-by: David Hildenbrand <david@...hat.com>
> Signed-off-by: Laurent Dufour <ldufour@...ux.ibm.com>
[...]
> diff --git a/include/linux/memory_hotplug.h b/include/linux/memory_hotplug.h
> index 375515803cd8..cd2bd21d3a4d 100644
> --- a/include/linux/memory_hotplug.h
> +++ b/include/linux/memory_hotplug.h
> @@ -15,6 +15,15 @@ struct memory_block;
> struct resource;
> struct vmem_altmap;
>
> +/*
> + * Memory plugin context, use to differentiate memory added at boot time and
> + * hot-plugged memory.
> + */
> +enum memplug_context {
> + MEMPLUG_EARLY,
> + MEMPLUG_HOTPLUG,
> +};
/*
* Memory initialization context, use to differentiate memory added by
* the platform statically or via memory hotplug interface.
*/
enum meminit_context {
MEMINIT_EARLY,
MEMINIT_HOTPLUG
}
--
Michal Hocko
SUSE Labs
Powered by blists - more mailing lists