[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <5a8002bd-2eaa-5acd-d7ad-b651dd5e4fbb@codeaurora.org>
Date: Thu, 17 Sep 2020 11:20:08 -0700
From: Siddharth Gupta <sidgup@...eaurora.org>
To: agross@...nel.org, bjorn.andersson@...aro.org, ohad@...ery.com
Cc: linux-remoteproc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-msm@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, tsoni@...eaurora.org,
psodagud@...eaurora.org, rishabhb@...eaurora.org,
linux-doc@...r.kernel.org
Subject: Re: [PATCH v4 0/3] Introduce mini-dump support for remoteproc
Gentle remind to review this patch series.
Thanks,
Sid
On 9/10/2020 11:57 AM, Siddharth Gupta wrote:
> Sometimes firmware sizes can be in ten's of MB's and reading
> all the memory during coredump can consume lot of time and
> memory.
> Introducing support for mini-dumps. Mini-dump contains smallest
> amount of useful information, that could help to debug subsystem
> crashes.
> During bootup memory is allocated in SMEM (Shared memory)
> in the form of a table that contains the physical
> addresses and sizes of the regions that are supposed to be
> collected during coredump. This memory is shared amongst all
> processors in a Qualcomm platform, so all remoteprocs
> fill in their entry in the global table once they are out
> of reset.
> This patch series adds support for parsing the global minidump
> table and uses the current coredump frameork to expose this memory
> to userspace during remoteproc's recovery.
>
> This patch series also integrates the patch:
> https://patchwork.kernel.org/patch/11695541/ sent by Siddharth.
>
> Changelog:
> v3 -> v4:
> - Made adsp_priv_cleanup a static function.
>
> v2 -> v3:
> - Refactored code to remove dependency on Qualcomm configs.
> - Renamed do_rproc_minidump to rproc_minidump and marked as exported
> symbol.
>
> v1 -> v2:
> - 3 kernel test robot warnings have been resolved.
> - Introduced priv_cleanup op in order to making the cleaning of
> private elements used by the remoteproc more readable.
> - Removed rproc_cleanup_priv as it is no longer needed.
> - Switched to if/else format for rproc_alloc in order to keep
> the static const decalaration of adsp_minidump_ops.
>
> Siddharth Gupta (3):
> remoteproc: core: Add ops to enable custom coredump functionality
> remoteproc: qcom: Add capability to collect minidumps
> remoteproc: qcom: Add minidump id for sm8150 modem remoteproc
>
> drivers/remoteproc/qcom_minidump.h | 64 +++++++++++++
> drivers/remoteproc/qcom_q6v5_pas.c | 107 ++++++++++++++++++++-
> drivers/remoteproc/remoteproc_core.c | 6 +-
> drivers/remoteproc/remoteproc_coredump.c | 138 ++++++++++++++++++++++++++++
> drivers/remoteproc/remoteproc_elf_helpers.h | 27 ++++++
> include/linux/remoteproc.h | 5 +
> 6 files changed, 344 insertions(+), 3 deletions(-)
> create mode 100644 drivers/remoteproc/qcom_minidump.h
>
Powered by blists - more mailing lists