[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b9b0a159-905b-6d18-6b7c-db63c2f61c0d@ti.com>
Date: Thu, 17 Sep 2020 06:42:02 -0500
From: Dan Murphy <dmurphy@...com>
To: Camel Guo <camel.guo@...s.com>, <lgirdwood@...il.com>,
<broonie@...nel.org>, <tiwai@...e.com>, <robh+dt@...nel.org>,
<devicetree@...r.kernel.org>
CC: <alsa-devel@...a-project.org>, <linux-kernel@...r.kernel.org>,
<kernel@...s.com>, Camel Guo <camelg@...s.com>
Subject: Re: [PATCH v3 2/2] ASoC: tlv320adcx140: Add support for configuring
GPIO pin
Camel
On 9/16/20 2:59 AM, Camel Guo wrote:
> From: Camel Guo <camelg@...s.com>
>
> Add support to configure the GPIO pin to the specific configuration.
> The GPIO pin can be configured as GPO, IRQ, SDOUT2, PDMCLK, MICBASE_EN,
> GPI, MCLK, SDIN, PDMDIN1, PDMDIN2, PDMDIN3 or PDMDIN4 and the output
> drive can be configured with various configuration.
>
> Signed-off-by: Camel Guo <camelg@...s.com>
> ---
> v3:
> - Add ADCX140_NUM_GPIO_CFGS avoiding using magic number
> - Remove unneeded check on ret in adcx140_configure_gpio
>
> sound/soc/codecs/tlv320adcx140.c | 40 ++++++++++++++++++++++++++++++++
> sound/soc/codecs/tlv320adcx140.h | 5 ++++
> 2 files changed, 45 insertions(+)
>
> diff --git a/sound/soc/codecs/tlv320adcx140.c b/sound/soc/codecs/tlv320adcx140.c
> index f33ee604ee78..fe6fc6df66cc 100644
> --- a/sound/soc/codecs/tlv320adcx140.c
> +++ b/sound/soc/codecs/tlv320adcx140.c
> @@ -837,6 +837,42 @@ static int adcx140_configure_gpo(struct adcx140_priv *adcx140)
>
> }
>
> +static int adcx140_configure_gpio(struct adcx140_priv *adcx140)
> +{
> + int gpio_count = 0;
> + u32 gpio_outputs[ADCX140_NUM_GPIO_CFGS];
> + u32 gpio_output_val = 0;
> + int ret;
> +
> + gpio_count = device_property_count_u32(adcx140->dev,
> + "ti,gpio-config");
> + if (gpio_count == 0)
> + return 0;
> +
> + if (gpio_count != ADCX140_NUM_GPIO_CFGS)
> + return -EINVAL;
> +
> + ret = device_property_read_u32_array(adcx140->dev, "ti,gpio-config",
> + gpio_outputs, gpio_count);
> + if (ret)
> + return ret;
> +
> + if (gpio_outputs[0] > ADCX140_GPIO_CFG_MAX) {
> + dev_err(adcx140->dev, "GPIO config out of range\n");
> + return -EINVAL;
> + }
> +
> + if (gpio_outputs[1] > ADCX140_GPIO_DRV_MAX) {
> + dev_err(adcx140->dev, "GPIO drive out of range\n");
> + return -EINVAL;
> + }
> +
> + gpio_output_val = gpio_outputs[0] << ADCX140_GPIO_SHIFT
> + | gpio_outputs[1];
> +
> + return regmap_write(adcx140->regmap, ADCX140_GPIO_CFG0, gpio_output_val);
> +}
> +
> static int adcx140_codec_probe(struct snd_soc_component *component)
> {
> struct adcx140_priv *adcx140 = snd_soc_component_get_drvdata(component);
> @@ -934,6 +970,10 @@ static int adcx140_codec_probe(struct snd_soc_component *component)
> return ret;
> }
>
> + ret = adcx140_configure_gpio(adcx140);
> + if (ret)
> + return ret;
> +
> ret = adcx140_configure_gpo(adcx140);
> if (ret)
> goto out;
> diff --git a/sound/soc/codecs/tlv320adcx140.h b/sound/soc/codecs/tlv320adcx140.h
> index eedbc1d7221f..9d04dec374d1 100644
> --- a/sound/soc/codecs/tlv320adcx140.h
> +++ b/sound/soc/codecs/tlv320adcx140.h
> @@ -145,4 +145,9 @@
> #define ADCX140_GPO_CFG_MAX 4
> #define ADCX140_GPO_DRV_MAX 5
>
> +#define ADCX140_NUM_GPIO_CFGS 2
> +#define ADCX140_GPIO_SHIFT 4
> +#define ADCX140_GPIO_CFG_MAX 15
> +#define ADCX140_GPIO_DRV_MAX 5
> +
> #endif /* _TLV320ADCX140_ */
Acked-by: Dan Murphy <dmurphy@...com>
Powered by blists - more mailing lists