[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c49cf22c-7b34-a7d2-c7d2-ac322150e4a6@redhat.com>
Date: Fri, 18 Sep 2020 09:23:16 +0200
From: David Hildenbrand <david@...hat.com>
To: Wei Yang <richard.weiyang@...ux.alibaba.com>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
linux-hyperv@...r.kernel.org, xen-devel@...ts.xenproject.org,
linux-acpi@...r.kernel.org,
Andrew Morton <akpm@...ux-foundation.org>,
Alexander Duyck <alexander.h.duyck@...ux.intel.com>,
Mel Gorman <mgorman@...hsingularity.net>,
Michal Hocko <mhocko@...nel.org>,
Dave Hansen <dave.hansen@...el.com>,
Vlastimil Babka <vbabka@...e.cz>,
Oscar Salvador <osalvador@...e.de>,
Mike Rapoport <rppt@...nel.org>
Subject: Re: [PATCH RFC 1/4] mm/page_alloc: convert "report" flag of
__free_one_page() to a proper flag
On 18.09.20 03:53, Wei Yang wrote:
> On Wed, Sep 16, 2020 at 08:34:08PM +0200, David Hildenbrand wrote:
>> Let's prepare for additional flags and avoid long parameter lists of bools.
>> Follow-up patches will also make use of the flags in __free_pages_ok(),
>> however, I wasn't able to come up with a better name for the type - should
>> be good enough for internal purposes.
>>
>> Cc: Andrew Morton <akpm@...ux-foundation.org>
>> Cc: Alexander Duyck <alexander.h.duyck@...ux.intel.com>
>> Cc: Mel Gorman <mgorman@...hsingularity.net>
>> Cc: Michal Hocko <mhocko@...nel.org>
>> Cc: Dave Hansen <dave.hansen@...el.com>
>> Cc: Vlastimil Babka <vbabka@...e.cz>
>> Cc: Wei Yang <richard.weiyang@...ux.alibaba.com>
>> Cc: Oscar Salvador <osalvador@...e.de>
>> Cc: Mike Rapoport <rppt@...nel.org>
>> Signed-off-by: David Hildenbrand <david@...hat.com>
>> ---
>> mm/page_alloc.c | 28 ++++++++++++++++++++--------
>> 1 file changed, 20 insertions(+), 8 deletions(-)
>>
>> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
>> index 6b699d273d6e..91cefb8157dd 100644
>> --- a/mm/page_alloc.c
>> +++ b/mm/page_alloc.c
>> @@ -77,6 +77,18 @@
>> #include "shuffle.h"
>> #include "page_reporting.h"
>>
>> +/* Free One Page flags: for internal, non-pcp variants of free_pages(). */
>> +typedef int __bitwise fop_t;
>> +
>> +/* No special request */
>> +#define FOP_NONE ((__force fop_t)0)
>> +
>> +/*
>> + * Skip free page reporting notification after buddy merging (will *not* mark
>
> __free_one_page() may not merge buddy when its buddy is not available.
>
> Would this comment be a little confusing?
>
I rather meant the process than if it's actually happening.
"Skip free page reporting notification for the (possibly merged) page."
Thanks!
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists